summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-21 23:26:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-21 23:28:36 +0200
commit334d47b15e237a864bae536508e86c86984f4640 (patch)
tree92f65daf649adc405f29872e6da7763a4e91789d /dev-python/cached-property/cached-property-1.5.2.ebuild
parentgames-board/gnome-hearts: fix HOMEPAGE (diff)
downloadgentoo-334d47b15e237a864bae536508e86c86984f4640.tar.gz
gentoo-334d47b15e237a864bae536508e86c86984f4640.tar.bz2
gentoo-334d47b15e237a864bae536508e86c86984f4640.zip
dev-python/cached-property: Bump to 1.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cached-property/cached-property-1.5.2.ebuild')
-rw-r--r--dev-python/cached-property/cached-property-1.5.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/cached-property/cached-property-1.5.2.ebuild b/dev-python/cached-property/cached-property-1.5.2.ebuild
new file mode 100644
index 000000000000..819cd6b14ebf
--- /dev/null
+++ b/dev-python/cached-property/cached-property-1.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A cached-property for decorating methods in classes"
+HOMEPAGE="https://github.com/pydanny/cached-property"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # bug 638250
+ eapply "${FILESDIR}"/${PN}-1.5.1-test-failure.patch
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ dodoc README.rst HISTORY.rst CONTRIBUTING.rst AUTHORS.rst
+ distutils-r1_python_install_all
+}