summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2019-07-01 21:17:35 +1000
committerMichael Palimaka <kensington@gentoo.org>2019-07-01 21:27:02 +1000
commitca31229b127c0151a740ceec5d2a7649f4f44544 (patch)
tree303e7011ff41ab4ca245cb159d5a6761e7d146e9 /dev-python/cachelib/cachelib-0.1.ebuild
parentapp-backup/burp: depend on acct-{user,group}/burp (diff)
downloadgentoo-ca31229b127c0151a740ceec5d2a7649f4f44544.tar.gz
gentoo-ca31229b127c0151a740ceec5d2a7649f4f44544.tar.bz2
gentoo-ca31229b127c0151a740ceec5d2a7649f4f44544.zip
dev-python/cachelib: new package
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'dev-python/cachelib/cachelib-0.1.ebuild')
-rw-r--r--dev-python/cachelib/cachelib-0.1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/cachelib/cachelib-0.1.ebuild b/dev-python/cachelib/cachelib-0.1.ebuild
new file mode 100644
index 000000000000..492ed3c8d99a
--- /dev/null
+++ b/dev-python/cachelib/cachelib-0.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Collection of cache libraries in the same API interface. Extracted from werkzeug"
+HOMEPAGE="https://pypi.org/project/cachelib/ https://github.com/pallets/cachelib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"