summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 09:50:24 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 10:51:32 +0100
commitc04bbd160e25f7dcb37b92d7630371a241aa30f3 (patch)
tree3f447bd4aed50195978f86a41fba52aae4edafd6 /dev-python/cachelib
parentwww-servers/uwsgi: Enable py3.10 (diff)
downloadgentoo-c04bbd160e25f7dcb37b92d7630371a241aa30f3.tar.gz
gentoo-c04bbd160e25f7dcb37b92d7630371a241aa30f3.tar.bz2
gentoo-c04bbd160e25f7dcb37b92d7630371a241aa30f3.zip
dev-python/cachelib: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cachelib')
-rw-r--r--dev-python/cachelib/Manifest1
-rw-r--r--dev-python/cachelib/cachelib-0.6.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/cachelib/Manifest b/dev-python/cachelib/Manifest
index 77695239c4d0..d7349da3ce58 100644
--- a/dev-python/cachelib/Manifest
+++ b/dev-python/cachelib/Manifest
@@ -1,2 +1,3 @@
DIST cachelib-0.4.1.tar.gz 19762 BLAKE2B baadfe920fda339cd8f3241664ae91b2767423ed09bdb6204573b2679e37c2dd3157f3b4d0f16841b1ab859f7c777986c0c251bcbe4bdf1ade69c442ff8ec756 SHA512 051e6f31b6ee58836a1512de4c7eedc718c081389df92605ad065f4bc5e4c861971507af636686d8abf00273a379ff31730bf040a7633a143dc1492263e3a543
DIST cachelib-0.5.0.tar.gz 21173 BLAKE2B cbd6bb5e0be27dd284893ebd3e469821806c5d3634195b6cacc4ba247da9f8f3d33d0ad3043e80409f836907c24c1a8226dd0333a51488b86a7cd0244d66fe2b SHA512 1b942e654cf334755fe130a913504d6b46dbb1e6aef3df33cb295ded7e47b1ed461b68653d8bc8ffe85cff6fc82a382df82b97302ff191e184e953d837a02cdd
+DIST cachelib-0.6.0.tar.gz 21842 BLAKE2B a886e0d6558dd7b3e5cb70124ac48b1fd55de13bc15998da32111300505501252f96c419c2bf82f6101c51e70d2d98f5a49362554891513ea3d1c8522d17ab4c SHA512 a828b6a9e425efcfbae46c148f1f56fd6f4df2ce37ed72b90fc4c3ea9edec1273aa2f2e1f9ad59fad30d1b8e37d6794176b85a7b5afb2b65264bd992dfc5c4f6
diff --git a/dev-python/cachelib/cachelib-0.6.0.ebuild b/dev-python/cachelib/cachelib-0.6.0.ebuild
new file mode 100644
index 000000000000..d34a088c6227
--- /dev/null
+++ b/dev-python/cachelib/cachelib-0.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of cache libraries in the same API interface. Extracted from werkzeug"
+HOMEPAGE="https://pypi.org/project/cachelib/ https://github.com/pallets/cachelib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ net-misc/memcached
+ www-servers/uwsgi[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # bug #818523
+ tests/test_redis_cache.py
+)