summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-27 19:02:01 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-27 19:46:48 -0500
commit73562e494634c4105234c49d78a34b6162b9f4fc (patch)
treed6630f43eefcf39e8969247314926e158548be8e /dev-python/cursive/cursive-0.1.2.ebuild
parentdev-python/WSME: 0.9.2 bup (diff)
downloadgentoo-73562e494634c4105234c49d78a34b6162b9f4fc.tar.gz
gentoo-73562e494634c4105234c49d78a34b6162b9f4fc.tar.bz2
gentoo-73562e494634c4105234c49d78a34b6162b9f4fc.zip
dev-python/cursive: 0.1.2 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/cursive/cursive-0.1.2.ebuild')
-rw-r--r--dev-python/cursive/cursive-0.1.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/cursive/cursive-0.1.2.ebuild b/dev-python/cursive/cursive-0.1.2.ebuild
new file mode 100644
index 000000000000..0b9d87d49026
--- /dev/null
+++ b/dev-python/cursive/cursive-0.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cursive implements OpenStack-specific validation of digital signatures."
+HOMEPAGE="https://github.com/openstack/cursive"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]"