summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-28 19:10:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-28 19:17:31 +0200
commit0c517f9c08c1ee5b12c896643678064b2ea1bb7a (patch)
treeed765ed582720028c35beb6fd95943599538f064 /dev-python/cx_Freeze
parentdev-python/pytest-datafiles: New package, v3.0.0 (diff)
downloadgentoo-0c517f9c08c1ee5b12c896643678064b2ea1bb7a.tar.gz
gentoo-0c517f9c08c1ee5b12c896643678064b2ea1bb7a.tar.bz2
gentoo-0c517f9c08c1ee5b12c896643678064b2ea1bb7a.zip
dev-python/cx_Freeze: Bump to 6.15.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cx_Freeze')
-rw-r--r--dev-python/cx_Freeze/Manifest1
-rw-r--r--dev-python/cx_Freeze/cx_Freeze-6.15.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/cx_Freeze/Manifest b/dev-python/cx_Freeze/Manifest
index 77c0f944e482..1855f7856922 100644
--- a/dev-python/cx_Freeze/Manifest
+++ b/dev-python/cx_Freeze/Manifest
@@ -3,3 +3,4 @@ DIST cx_Freeze-6.14.5.gh.tar.gz 1648095 BLAKE2B 81707d17c2118a8db4d768b2fbe83278
DIST cx_Freeze-6.14.9.gh.tar.gz 1649748 BLAKE2B 08fefea6ed9610b672ca8a4a6e480cedf8fd75c967880e74f94c12368ec1ff71a9d34baae02342f7c4484e65beda5dc71dd39e13b8c340c5b7dd2e89b38ba0f1 SHA512 bfe3e5d3dcf96cff448b034a779b93c37dacda489ee4eabd92e8f4708c6d7a9fe2430bc512f40c6af8c6f851fff24a3626b80f10295af1357e4a58563474e8eb
DIST cx_Freeze-6.15.0.gh.tar.gz 1650636 BLAKE2B 9d99a78bc4d6b6498e10c54352a6fbfce3f2ee9bba9cc5b7fa752eba465d29355c6e4222e4f3c3012793820f435591f2e3e634e512765720d0c96a7799ab5998 SHA512 90fc3fba50ab7a9a263371fc9e57df768792b78175cd7ed39f2308b2a5e6bf0eb992616d29ff0d34c8bf040d167bac1882e0e1d2425d2f248e4de2e755c72503
DIST cx_Freeze-6.15.1.gh.tar.gz 1651345 BLAKE2B 9c0c29f19e09184ad7b0a6954649c30fa1c941ff822b1c5ec745b1a6c7dd58fc77b06c070641a9200fc4910bdfc49937841ba2b547b16ec48f9fd30dfee6cd03 SHA512 d6540736d437242fd89fc34f0ff81691eebb455c0ddca8b90ee6ec436105d908e9fed580a08e23999f70b5e3aa2f2e66ee35eec092eecab0501e9b3117af23b3
+DIST cx_Freeze-6.15.2.gh.tar.gz 1655639 BLAKE2B 303b3d541cae2e0ef98ea0c57a693092c177cb9e308ae44ee0a9972a9a4b34298ddd0deb86d49d9a0ce9f1f1ea480edd45aa4e63eeca1ce86a1b348c10b7caee SHA512 2f6dc0bed9981190411b1ac12c6a5a8c7907cf059d50e01bc1958308b8f905d818aff12262712ecc7ee931a0976fae0fbef7dd35433158122386d7b6a9a3b3eb
diff --git a/dev-python/cx_Freeze/cx_Freeze-6.15.2.ebuild b/dev-python/cx_Freeze/cx_Freeze-6.15.2.ebuild
new file mode 100644
index 000000000000..23a35531d174
--- /dev/null
+++ b/dev-python/cx_Freeze/cx_Freeze-6.15.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create standalone executables from Python scripts"
+HOMEPAGE="
+ https://cx-freeze.readthedocs.io/
+ https://github.com/marcelotduarte/cx_Freeze/
+ https://pypi.org/project/cx-Freeze/
+"
+SRC_URI="
+ https://github.com/marcelotduarte/cx_Freeze/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ ' 3.9)
+ dev-util/patchelf
+ virtual/libcrypt:=
+"
+BDEPEND="
+ test? (
+ app-arch/rpm
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-datafiles[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # bug #491602
+ "${FILESDIR}/${PN}-6.8.2-buildsystem.patch"
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove pythonic dep on patchelf exec
+ sed -i -e '/patchelf/d' pyproject.toml || die
+ # remove repeatedly outdated upper bound on setuptools
+ sed -i -e '/setuptools/s:,<[0-9.]*::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # rpm test expects .pyc
+ local -x PYTHONDONTWRITEBYTECODE=
+ rm -rf cx_Freeze || die
+ epytest
+}