summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-13 08:37:22 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-13 08:41:29 +0100
commit652e752f01bc93a591303d332681cd6dce81596f (patch)
tree25b2bea695637fdd7c438aef23d404f2bace1e11 /dev-python/ddt/ddt-1.4.2.ebuild
parentdev-util/pkgcheck: Bump to 0.9.3 (diff)
downloadgentoo-652e752f01bc93a591303d332681cd6dce81596f.tar.gz
gentoo-652e752f01bc93a591303d332681cd6dce81596f.tar.bz2
gentoo-652e752f01bc93a591303d332681cd6dce81596f.zip
dev-python/ddt: Bump to 1.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ddt/ddt-1.4.2.ebuild')
-rw-r--r--dev-python/ddt/ddt-1.4.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ddt/ddt-1.4.2.ebuild b/dev-python/ddt/ddt-1.4.2.ebuild
new file mode 100644
index 000000000000..209e1ee4913f
--- /dev/null
+++ b/dev-python/ddt/ddt-1.4.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to multiply test cases"
+HOMEPAGE="
+ https://pypi.org/project/ddt/
+ https://github.com/datadriventests/ddt/"
+SRC_URI="
+ https://github.com/datadriventests/ddt/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest