summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-11 12:36:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-11 13:03:12 +0200
commit701fdbdd8b8e13b68ec18392efc6f02678de3ce2 (patch)
tree7f6e0d1a2bce734ccd994110cd17e4048fcc7036 /dev-python/defusedxml
parentdev-python/pytest-regressions: Enable py3.13 (diff)
downloadgentoo-701fdbdd8b8e13b68ec18392efc6f02678de3ce2.tar.gz
gentoo-701fdbdd8b8e13b68ec18392efc6f02678de3ce2.tar.bz2
gentoo-701fdbdd8b8e13b68ec18392efc6f02678de3ce2.zip
dev-python/defusedxml: Bump to 0.8.0_rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/defusedxml')
-rw-r--r--dev-python/defusedxml/Manifest1
-rw-r--r--dev-python/defusedxml/defusedxml-0.8.0_rc2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/defusedxml/Manifest b/dev-python/defusedxml/Manifest
index 22b9f00fa8b8..5ad9bba1c92c 100644
--- a/dev-python/defusedxml/Manifest
+++ b/dev-python/defusedxml/Manifest
@@ -1 +1,2 @@
DIST defusedxml-0.7.1.gh.tar.gz 34709 BLAKE2B cfe69851e0ac6472cb9e66d1b577831eec37b0a01129dcb43cec151aa939029efc194220f3c7b481d306a77db710a639bdd56f3fd1f7ae46fa4ab8f308b8036f SHA512 4f536794b814291520c7db27765014c57f415554cff569cddab596b33e1aa03799aae9448fdaf07417d1a9f4d8782aa827d1b68aac6881ffe5c2ca9b8a40d864
+DIST defusedxml-0.8.0rc2.gh.tar.gz 37727 BLAKE2B 4a9313c4fe171998b84e22cf1cd2e5781cea6d37ea2436c5450fe4d003c915d3c945c8385b172fc102b601abb4612a217265bdd293f5d20ece2896194e37366a SHA512 d0cdaebf459a203c09c679169eeadc076a92b913558924cc6d3d693fe5732cefd5a6d15c4d2cbcdd7710936063a96e6dca467d0a82165194abeb7111d910daee
diff --git a/dev-python/defusedxml/defusedxml-0.8.0_rc2.ebuild b/dev-python/defusedxml/defusedxml-0.8.0_rc2.ebuild
new file mode 100644
index 000000000000..871461648d52
--- /dev/null
+++ b/dev-python/defusedxml/defusedxml-0.8.0_rc2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+MY_P=${P/_/}
+DESCRIPTION="XML bomb protection for Python stdlib modules, an xml serialiser"
+HOMEPAGE="
+ https://github.com/tiran/defusedxml/
+ https://pypi.org/project/defusedxml/
+"
+SRC_URI="
+ https://github.com/tiran/defusedxml/archive/v${PV/_/}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e 's:verbosity=1:verbosity=2:' tests.py || die
+ mv other examples || die
+}
+
+python_test() {
+ "${EPYTHON}" tests.py -v || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples/
+ distutils-r1_python_install_all
+}