summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-29 05:16:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-29 05:36:02 +0100
commitbd496d275feba1f11a73d59f496fb33765397ddd (patch)
treec9ba9e056f874d8795a2a9248b63885acd68d651 /dev-python/denonavr
parentdev-python/denonavr: Remove old (diff)
downloadgentoo-bd496d275feba1f11a73d59f496fb33765397ddd.tar.gz
gentoo-bd496d275feba1f11a73d59f496fb33765397ddd.tar.bz2
gentoo-bd496d275feba1f11a73d59f496fb33765397ddd.zip
dev-python/denonavr: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/denonavr')
-rw-r--r--dev-python/denonavr/Manifest1
-rw-r--r--dev-python/denonavr/denonavr-1.0.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
index e280d9e47eef..400251fd3b63 100644
--- a/dev-python/denonavr/Manifest
+++ b/dev-python/denonavr/Manifest
@@ -1 +1,2 @@
DIST denonavr-1.0.0.tar.gz 182189 BLAKE2B 044f5bc2dd37ecf58c0c13c56c638c8e336b206eb6a6333364ee72af0b9dcf309b85ae0ae701a3da5e7b02211f4baa5c109f71bbda03fec5075dd27f823a25c5 SHA512 8c562dd61d1cfec6110c880e1c052f8234b2d026791aafd528c526f55decbfc7f57ecb06bf4668ed2a7abd9fc2fa1cef12991dab7bb7368847356e21517a237b
+DIST denonavr-1.0.1.tar.gz 182654 BLAKE2B 27e2cda7fedb67fcb693d1d95bbc4d19e1e23c50b34b2949c5254803632735860468c39fec128edfe2657ef4cac9b57880251345a5556866de9703d3cf3abf88 SHA512 3d8b433574bd51bba5750c12b451025082de41da95d1d2907d6e63820d244ce051a52519a1d5c061df447ae7498ff8178d0c7c58624d460a7cab8db3e3d27e29
diff --git a/dev-python/denonavr/denonavr-1.0.1.ebuild b/dev-python/denonavr/denonavr-1.0.1.ebuild
new file mode 100644
index 000000000000..2f160c89d6eb
--- /dev/null
+++ b/dev-python/denonavr/denonavr-1.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="
+ https://github.com/ol-iver/denonavr/
+ https://pypi.org/project/denonavr/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/ftfy-6.1.1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23.1[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest