summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-24 14:53:27 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-25 18:18:23 +0100
commitbe194de164f2bbcacaa804d9bb176cdd21b9d65f (patch)
treef10eb0a8782dd9e536ce944ca14ba32de2e96301 /dev-python/discogs-client
parentdev-python/cherrypy: Use pypi.eclass (diff)
downloadgentoo-be194de164f2bbcacaa804d9bb176cdd21b9d65f.tar.gz
gentoo-be194de164f2bbcacaa804d9bb176cdd21b9d65f.tar.bz2
gentoo-be194de164f2bbcacaa804d9bb176cdd21b9d65f.zip
dev-python/discogs-client: Use pypi.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/discogs-client')
-rw-r--r--dev-python/discogs-client/discogs-client-2.6.ebuild5
-rw-r--r--dev-python/discogs-client/discogs-client-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/discogs-client/discogs-client-2.6.ebuild b/dev-python/discogs-client/discogs-client-2.6.ebuild
index 3e7d1008f56c..002e78b02b10 100644
--- a/dev-python/discogs-client/discogs-client-2.6.ebuild
+++ b/dev-python/discogs-client/discogs-client-2.6.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="python3-discogs-client"
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -12,9 +14,8 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
inherit git-r3
else
- SRC_URI="mirror://pypi/p/python3-${PN}/python3-${P}.tar.gz"
+ inherit pypi
KEYWORDS="amd64 ~x86"
- S="${WORKDIR}/python3-${P}"
fi
DESCRIPTION="Continuation of the official Python API client for Discogs"
diff --git a/dev-python/discogs-client/discogs-client-9999.ebuild b/dev-python/discogs-client/discogs-client-9999.ebuild
index 38145b329c13..9d6289c122b8 100644
--- a/dev-python/discogs-client/discogs-client-9999.ebuild
+++ b/dev-python/discogs-client/discogs-client-9999.ebuild
@@ -4,6 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="python3-discogs-client"
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -12,9 +14,8 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
inherit git-r3
else
- SRC_URI="mirror://pypi/p/python3-${PN}/python3-${P}.tar.gz"
+ inherit pypi
KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/python3-${P}"
fi
DESCRIPTION="Continuation of the official Python API client for Discogs"