summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 09:34:22 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 10:05:36 +0200
commita1da6ff13d3f2df555fdc56655c38c04c527f023 (patch)
tree87b20051d16a86fa60b0d34d17b279b3acdb6101 /dev-python/django-cors-headers
parentdev-python/translate-toolkit: Bump to 3.6.2 (diff)
downloadgentoo-a1da6ff13d3f2df555fdc56655c38c04c527f023.tar.gz
gentoo-a1da6ff13d3f2df555fdc56655c38c04c527f023.tar.bz2
gentoo-a1da6ff13d3f2df555fdc56655c38c04c527f023.zip
dev-python/django-cors-headers: Bump to 3.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cors-headers')
-rw-r--r--dev-python/django-cors-headers/Manifest1
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-3.12.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/django-cors-headers/Manifest b/dev-python/django-cors-headers/Manifest
index 081bb5fe6fe3..dfcf9bbb3947 100644
--- a/dev-python/django-cors-headers/Manifest
+++ b/dev-python/django-cors-headers/Manifest
@@ -1 +1,2 @@
DIST django-cors-headers-3.10.1.gh.tar.gz 29478 BLAKE2B 935167699b8c63b4741ff095a0dcfb4a0875a424e6f452989b788eb1f97147be4792c8d0304cdf1cfc6f6c339cb27bc7f701c0ae1c379bfe573031c1a2d67c14 SHA512 7c5e94fd59ae4ae542386c9d307ed2628b2e3cb8bd5f48e004b3a84b311acd269a2ba2faf6d034c6cab5f7a0d6e781b4c7ee7c64da8a486a46610af723ee448c
+DIST django-cors-headers-3.12.0.gh.tar.gz 26638 BLAKE2B 7725f7db4e9a67d7cd7f4add74abb5bfd27bac4c65cf4120dee3ba412c27fd89d6e39502249ea4b253c6a7d7d0f5328296ed69ac8b3ceb337bbb89a04f93a6ce SHA512 16d1d03bf1f5336703168280ff585168eb239f454aaec1f1e9928a362c7e7da17b54e896d7428ecdc91657045bede0b3c239a7f2f271c58c1b7b265b2e52aef5
diff --git a/dev-python/django-cors-headers/django-cors-headers-3.12.0.ebuild b/dev-python/django-cors-headers/django-cors-headers-3.12.0.ebuild
new file mode 100644
index 000000000000..11302037f21b
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-3.12.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="
+ https://github.com/adamchainz/django-cors-headers/
+ https://pypi.org/project/django-cors-headers/
+"
+SRC_URI="
+ https://github.com/adamchainz/django-cors-headers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest