summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-14 10:52:45 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-14 10:53:37 +0100
commit848bd2188dba9079f4725476606a3173cad25cd8 (patch)
treef238af50ea289a5b89acdb1b95964a115eb21910 /dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild
parentdev-python/pyzmq: Version Bump (diff)
downloadgentoo-848bd2188dba9079f4725476606a3173cad25cd8.tar.gz
gentoo-848bd2188dba9079f4725476606a3173cad25cd8.tar.bz2
gentoo-848bd2188dba9079f4725476606a3173cad25cd8.zip
dev-python/django-crispy-forms: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild')
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild
new file mode 100644
index 000000000000..b87d00a21469
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Best way to have Django DRY forms"
+HOMEPAGE="
+ https://pypi.python.org/pypi/django-crispy-forms/
+ https://github.com/maraujop/django-crispy-forms
+ https://django-crispy-forms.readthedocs.org/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Seems to be incompletely packed
+RESTRICT=test
+
+python_test() {
+ DJANGO_SETTINGS_MODULE=crispy_forms.tests.test_settings py.test crispy_forms/tests || die
+}