summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-04 20:54:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-04 22:33:02 +0200
commit87022cc167fe80ab6c4387791a92a1274f68c7db (patch)
treef3363932ec5db0b56de0901d205dcefe1153b216 /dev-python/django-otp
parentdev-python/django-otp: Remove old (diff)
downloadgentoo-87022cc167fe80ab6c4387791a92a1274f68c7db.tar.gz
gentoo-87022cc167fe80ab6c4387791a92a1274f68c7db.tar.bz2
gentoo-87022cc167fe80ab6c4387791a92a1274f68c7db.zip
dev-python/django-otp: Bump to 1.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest1
-rw-r--r--dev-python/django-otp/django-otp-1.5.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index 8026e9c852b2..080874325222 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1 +1,2 @@
DIST django_otp-1.5.2.tar.gz 73778 BLAKE2B 290afbb0a9f2f6ad41ecdb3d65003b0abf4838776241b00957bdbe7303335a33f99eb9e4c23454500fc92d03595a6fb393dd18ba6341e8dde789e21cfabda114 SHA512 5fa8ce6652b6849a7bc347e34addf2b4f694d0116d8c9574fa12d5f2e9313240b69fe4e9058317e202750e453af2882eb24d33d39a7104c458f2337c921901ee
+DIST django_otp-1.5.3.tar.gz 73785 BLAKE2B 0f69539b271c7ed4cac55e6f52c4f8b67761731df14eef7594d3430b89e44c3b4314084a6ddeb02b85b4b576fffe2c20097e5bad291de2020f2314042d374348 SHA512 c101996982182736743cb14f44cc055722cc510e2082ee312f91b79cf9d87b50aaa1eeec489649723514e7150469be9c7f4f2d71758a7a72d0dffe04f4f875a9
diff --git a/dev-python/django-otp/django-otp-1.5.3.ebuild b/dev-python/django-otp/django-otp-1.5.3.ebuild
new file mode 100644
index 000000000000..3dc062125747
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.5.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="
+ https://github.com/django-otp/django-otp/
+ https://pypi.org/project/django-otp/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ || (
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/segno[${PYTHON_USEDEP}]
+ )
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ "${EPYTHON}" -m django test -v 2 django_otp ||
+ die "Tests fail with ${EPYTHON}"
+}