summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-07-16 09:07:26 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-07-16 09:12:29 -0500
commitf40a642d35c53a1f036609d70b45a516d67bf22e (patch)
tree11a07b10b3fb851bcf372d49bce1bf1b6d0a9e43 /dev-python/docker-py/docker-py-1.9.0_rc2.ebuild
parentdev-python/setproctitle: update HOMEPAGE. (diff)
downloadgentoo-f40a642d35c53a1f036609d70b45a516d67bf22e.tar.gz
gentoo-f40a642d35c53a1f036609d70b45a516d67bf22e.tar.bz2
gentoo-f40a642d35c53a1f036609d70b45a516d67bf22e.zip
dev-python/docker-py: add version 1.9.0_rc2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/docker-py/docker-py-1.9.0_rc2.ebuild')
-rw-r--r--dev-python/docker-py/docker-py-1.9.0_rc2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/docker-py/docker-py-1.9.0_rc2.ebuild b/dev-python/docker-py/docker-py-1.9.0_rc2.ebuild
new file mode 100644
index 000000000000..2c9b49851024
--- /dev/null
+++ b/dev-python/docker-py/docker-py-1.9.0_rc2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PV=${PV//_/-}
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/mkdocs-0.14.0[${PYTHON_USEDEP}] )
+ test? (
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ ~dev-python/pytest-2.7.2[${PYTHON_USEDEP}]
+ ~dev-python/pytest-cov-2.1.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_3' 'python3_4' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+
+python_compile_all() {
+ if use doc; then
+ mkdocs build -d 'mkdocs_site' || die "docs failed to build"
+ fi
+}
+
+python_test() {
+ py.test tests/unit/ | die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( mkdocs_site/. )
+
+ distutils-r1_python_install_all
+}