summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 11:12:56 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 11:15:42 +0200
commitbfd82c4913e5ee32f50958ac857307732282a971 (patch)
tree167f28bb114e0b132cfbdb06413bc4f4ada5f25f /dev-python/docutils
parentdev-python/genshi: Remove py2 (diff)
downloadgentoo-bfd82c4913e5ee32f50958ac857307732282a971.tar.gz
gentoo-bfd82c4913e5ee32f50958ac857307732282a971.tar.bz2
gentoo-bfd82c4913e5ee32f50958ac857307732282a971.zip
dev-python/docutils: Remove old (py2)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/docutils')
-rw-r--r--dev-python/docutils/docutils-0.16.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/docutils/docutils-0.16.ebuild b/dev-python/docutils/docutils-0.16.ebuild
deleted file mode 100644
index 9054e4d8eb73..000000000000
--- a/dev-python/docutils/docutils-0.16.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Documentation Utilities"
-HOMEPAGE="https://docutils.sourceforge.net/ https://pypi.org/project/docutils/"
-#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2 GPL-3 public-domain"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-tests.patch
-)
-
-python_compile_all() {
- # Generate html docs from reStructured text sources.
-
- # Place html4css1.css in base directory to ensure that the generated reference to it is correct.
- cp docutils/writers/html4css1/html4css1.css . || die
-
- cd tools || die
- "${EPYTHON}" buildhtml.py --input-encoding=utf-8 \
- --stylesheet-path=../html4css1.css, --traceback ../docs || die
-}
-
-src_test() {
- cd test || die
- distutils-r1_src_test
-}
-
-python_test() {
- "${EPYTHON}" alltests.py -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
-
- # Install tools.
- python_doscript tools/{buildhtml,quicktest}.py
-}
-
-install_txt_doc() {
- local doc="${1}"
- local dir="txt/$(dirname ${doc})"
- docinto "${dir}"
- dodoc "${doc}"
-}
-
-python_install_all() {
- local DOCS=( *.txt )
- local HTML_DOCS=( docs tools docutils/writers/html4css1/html4css1.css )
-
- distutils-r1_python_install_all
-
- local doc
- while IFS= read -r -d '' doc; do
- install_txt_doc "${doc}"
- done < <(find docs tools -name '*.txt' -print0)
-}