summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2017-08-14 20:23:47 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-15 22:54:13 +0200
commitbd36ce4c400a0e6ceb0106e9481cf8b18a24398d (patch)
treef075afe43344687e610e81a567c82c55bfcdef54 /dev-python/dogpile-cache/dogpile-cache-0.6.4.ebuild
parentdev-python/spyder: Fix metadata.xml (diff)
downloadgentoo-bd36ce4c400a0e6ceb0106e9481cf8b18a24398d.tar.gz
gentoo-bd36ce4c400a0e6ceb0106e9481cf8b18a24398d.tar.bz2
gentoo-bd36ce4c400a0e6ceb0106e9481cf8b18a24398d.zip
dev-python/dogpile-cache: version bump to 0.7.4.
This commit: * bumps EAPI to version 6. * enables python version 3.6. Tests now work with Python 2.7. Package-Manager: Portage-2.3.7, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5420
Diffstat (limited to 'dev-python/dogpile-cache/dogpile-cache-0.6.4.ebuild')
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-0.6.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.6.4.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.6.4.ebuild
new file mode 100644
index 000000000000..f42dbc5de8e0
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-0.6.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value."
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}] )"
+
+# This time half the doc files are missing; Do you want them? toss a coin
+
+python_test() {
+ "${EPYTHON}" ./setup.py test || die "test failed under ${EPYTHON}"
+}