summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-07-07 00:44:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-07 14:39:37 +0200
commit453f853494171c081e8e5f8e833682c55e7c21e8 (patch)
tree14527f16858a422e1b166e85c28ef42c3f657540 /dev-python/e4u
parentapp-emulation/libspectrum: remove old version 1.4.1 (diff)
downloadgentoo-453f853494171c081e8e5f8e833682c55e7c21e8.tar.gz
gentoo-453f853494171c081e8e5f8e833682c55e7c21e8.tar.bz2
gentoo-453f853494171c081e8e5f8e833682c55e7c21e8.zip
dev-python/e4u: fix tests
Closes: https://bugs.gentoo.org/660532 Package-Manager: Portage-2.3.41, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9075
Diffstat (limited to 'dev-python/e4u')
-rw-r--r--dev-python/e4u/e4u-0.1_rc5.ebuild5
-rw-r--r--dev-python/e4u/files/initialize-e4u-tests.patch11
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-python/e4u/e4u-0.1_rc5.ebuild b/dev-python/e4u/e4u-0.1_rc5.ebuild
index b52ae0edf6d2..018777c32b7c 100644
--- a/dev-python/e4u/e4u-0.1_rc5.ebuild
+++ b/dev-python/e4u/e4u-0.1_rc5.ebuild
@@ -25,7 +25,10 @@ DEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${MY_PV}"
-PATCHES=( "${FILESDIR}"/change-emoji4unicode-url.patch )
+PATCHES=(
+ "${FILESDIR}"/change-emoji4unicode-url.patch
+ "${FILESDIR}"/initialize-e4u-tests.patch
+)
python_test() {
esetup.py test
diff --git a/dev-python/e4u/files/initialize-e4u-tests.patch b/dev-python/e4u/files/initialize-e4u-tests.patch
new file mode 100644
index 000000000000..cc120ba3d488
--- /dev/null
+++ b/dev-python/e4u/files/initialize-e4u-tests.patch
@@ -0,0 +1,11 @@
+--- a/test/test.py 2018-05-22 08:32:05.000000000 +0200
++++ b/test/test.py 2018-07-07 00:41:02.861367660 +0200
+@@ -7,7 +7,7 @@
+ import unittest
+ import e4u
+
+-e4u.load()
++e4u.load(filename=r"./e4u/data/emoji4unicode.xml")
+
+ DISPLAY_INFO = False
+