summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-24 07:44:02 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-24 07:44:02 +0200
commit4a4832defd1cf40c4aee1e6f8e7759fc70b5b474 (patch)
treea54cb2c3fe242946de97e353f08e1d84ec1b8959 /dev-python/elementpath
parentdev-python/pyxattr: Remove py2 (diff)
downloadgentoo-4a4832defd1cf40c4aee1e6f8e7759fc70b5b474.tar.gz
gentoo-4a4832defd1cf40c4aee1e6f8e7759fc70b5b474.tar.bz2
gentoo-4a4832defd1cf40c4aee1e6f8e7759fc70b5b474.zip
dev-python/elementpath: Bump to 1.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-1.4.4.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index 4bfaabc7f9f9..2f2d9863137a 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1 +1,2 @@
DIST elementpath-1.4.3.tar.gz 117295 BLAKE2B 4ee29cf6c863c8c73aae26857266e1ac119082c3fa0f3bbb2a807b662f3bca03699e33f3a0043dc486d4de0e5484c5a559adb72681ba38851d02bac2a6093ac2 SHA512 3fb71d0eb333589995d2b4e75e56e001ecb57d7b3930ac6faa55ef8b05823ce3254979d7d27a1e8219487240edcb498bafa3198c212385164312839972e02dd9
+DIST elementpath-1.4.4.tar.gz 119577 BLAKE2B 65724afc715dcdb4903779933559e85c833cc262cecf2f53a86fd58e542717dc26137270bde13b5bdfcd81bb768a2dd74d7ed7213ad4292c0a1a2a4771855370 SHA512 39ce9f8e8f0a75690d5ccf5faa7e28113f971015c2baeec8b8f443b568c71154589d36dc2c5a3965eeb1d3d4257f65090cf44078747c7711bc7fc8c9ad051d43
diff --git a/dev-python/elementpath/elementpath-1.4.4.ebuild b/dev-python/elementpath/elementpath-1.4.4.ebuild
new file mode 100644
index 000000000000..fa02bf8a9d4a
--- /dev/null
+++ b/dev-python/elementpath/elementpath-1.4.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath
+ https://pypi.org/project/elementpath/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest