summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-17 08:34:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-17 09:22:29 +0200
commit01c4255bb5a13889cf64d8c6b91dc034109f5c21 (patch)
tree55dc43892e0a386b20acfb5849723fc6d2a78e81 /dev-python/emoji/emoji-2.0.0.ebuild
parentdev-python/confuse: Bump to 2.0.0 (diff)
downloadgentoo-01c4255bb5a13889cf64d8c6b91dc034109f5c21.tar.gz
gentoo-01c4255bb5a13889cf64d8c6b91dc034109f5c21.tar.bz2
gentoo-01c4255bb5a13889cf64d8c6b91dc034109f5c21.zip
dev-python/emoji: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/emoji/emoji-2.0.0.ebuild')
-rw-r--r--dev-python/emoji/emoji-2.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/emoji/emoji-2.0.0.ebuild b/dev-python/emoji/emoji-2.0.0.ebuild
new file mode 100644
index 000000000000..20469a0482c6
--- /dev/null
+++ b/dev-python/emoji/emoji-2.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Emoji for Python"
+HOMEPAGE="
+ https://github.com/carpedm20/emoji/
+ https://pypi.org/project/emoji/
+"
+SRC_URI="
+ https://github.com/carpedm20/emoji/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+distutils_enable_tests pytest