summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-30 03:38:31 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-30 04:25:43 +0100
commit4ce89933932104796b4423733b193bfdb6421a4f (patch)
treeb12d455ace338a2ddbd5cd8f2688f604ff076380 /dev-python/ensurepip-setuptools
parentapp-admin/awscli: Bump to 1.35.17 (diff)
downloadgentoo-4ce89933932104796b4423733b193bfdb6421a4f.tar.gz
gentoo-4ce89933932104796b4423733b193bfdb6421a4f.tar.bz2
gentoo-4ce89933932104796b4423733b193bfdb6421a4f.zip
dev-python/ensurepip-setuptools: Bump to 75.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ensurepip-setuptools')
-rw-r--r--dev-python/ensurepip-setuptools/Manifest1
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-75.3.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/Manifest b/dev-python/ensurepip-setuptools/Manifest
index 88ccf20ed75b..9666415abc0d 100644
--- a/dev-python/ensurepip-setuptools/Manifest
+++ b/dev-python/ensurepip-setuptools/Manifest
@@ -1,2 +1,3 @@
DIST setuptools-74.1.3-py3-none-any.whl 1262070 BLAKE2B 967e581556dee96b068a762605e340a7dbdb7eedb62fc2224fa3cbff8c29c6dd8966831bf4d2c4714401c8beca6ff81ba64823ec55ce592ff3bf10ddee370975 SHA512 8dd7f782ccbfcef04462904f3211569a2ca0be7f370a75cd1d77b77c1f38fcfbea8fd401646bbf436c093ad4573e32f0a0eef030644df48817fde43ae59ce0aa
DIST setuptools-75.2.0-py3-none-any.whl 1249825 BLAKE2B 10a48572cc684a39fe83ed47115e9e2cf7596421f1b5b9599b0472e3081b2d843b288dff85ad5d35133e80ac29db98856a03a7c8828a7394bcccf928e5b7d26d SHA512 5b30d02ee23ccd4615a2c63f9dc73b80453fa37b905b5c0d1aa18beb3688c24776d02e524db5ab6033ad4ba872ea04601970c1578235f38e0ec8d54597deaca3
+DIST setuptools-75.3.0-py3-none-any.whl 1251070 BLAKE2B 96cb4af06ae6f73f4cf86196d71c4ae3084f4f3ca945cf9873f1f466b0682fbc0816308fc0dff77c70d72966e65052939630c1551d7d04b879aa33319dddf601 SHA512 c3bdd2f5ebd5aaaeba190c847b04a2d789a17bd49cc277e1f5ca9613c17696b934560d64f9f194708ac655f5a4f478519550c3034f980bea1866d38c0d173659
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-75.3.0.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-75.3.0.ebuild
new file mode 100644
index 000000000000..c48c6a133f1f
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-75.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}