summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-10 05:37:49 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-10 05:37:49 +0100
commitfa48d896ef13373b9e27df0ba5db9a10ca6cb5c4 (patch)
tree72642e3b6ebc29d9f1494cc15d00fee063d8f10f /dev-python/environs
parentdev-python/braintree: Bump to 4.26.0 (diff)
downloadgentoo-fa48d896ef13373b9e27df0ba5db9a10ca6cb5c4.tar.gz
gentoo-fa48d896ef13373b9e27df0ba5db9a10ca6cb5c4.tar.bz2
gentoo-fa48d896ef13373b9e27df0ba5db9a10ca6cb5c4.zip
dev-python/environs: Bump to 10.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/environs')
-rw-r--r--dev-python/environs/Manifest1
-rw-r--r--dev-python/environs/environs-10.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/environs/Manifest b/dev-python/environs/Manifest
index db277cc6db18..e34d30ab6146 100644
--- a/dev-python/environs/Manifest
+++ b/dev-python/environs/Manifest
@@ -1,2 +1,3 @@
DIST environs-10.0.0.gh.tar.gz 23500 BLAKE2B c99a5972416a7959d06bb4541f6b319a948727386e621252e86389e3f271130917f6a056abe1363bd3bc4f10eb9d79107d9a6859fb4a745436fc35dd7a45e4d0 SHA512 4f2a485eb6a42687bd641f1468e70578eadaf01bd16fc121a9ba89725f560da1f1a4f0ba4476fbca561ffc6f4538c9a742b9335b89398d0abe09434e5e135957
DIST environs-10.1.0.gh.tar.gz 23613 BLAKE2B 6a0e47ba5397f21d4aa4026e8046a49f1a0f19f495725e9980786fe31b03ce492ce9233d279cb960c13a7d0b592034b643e3d719732d53fe0fb28ec15fc7c815 SHA512 5faf0e3e8fb67b01e4b809c817c5547914a499642324c0a9a2e2158e686ce80416656f29865cfee60e28e72360b6a65ec8045ef682a3a02ab49639f10e180bf5
+DIST environs-10.2.0.gh.tar.gz 23749 BLAKE2B 1da049ebe9af97cc3364ffed8cf749f28ffb30453303696f421220da5b1fb86d5965b4c218b4f24cb7ea28cdf78e7e51cb0994d379fb05f0330f033b6f58d778 SHA512 c6e9fe693b3d59b1d15dad66ac29aff1a7ade7a8e3199c613fc29b2c3741506e6d87c27962aa0e764fae37e37a0a797de0bf490ceebce38e6319223fe1cc5b87
diff --git a/dev-python/environs/environs-10.2.0.ebuild b/dev-python/environs/environs-10.2.0.ebuild
new file mode 100644
index 000000000000..eb57773697a8
--- /dev/null
+++ b/dev-python/environs/environs-10.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for simplified environment variable parsing"
+HOMEPAGE="
+ https://github.com/sloria/environs/
+ https://pypi.org/project/environs/
+"
+SRC_URI="
+ https://github.com/sloria/environs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/marshmallow[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/django-cache-url[${PYTHON_USEDEP}]
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ dev-python/dj-email-url[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+distutils_enable_tests pytest