summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-30 19:36:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-30 20:00:59 +0100
commit3a7bf5f8d6f4517a4f07cb9a6d5fd776e6f9ccba (patch)
tree37edf49a33f1459d6a519b60547206b3d6f1fd18 /dev-python/executing
parentdev-python/hypercorn: Bump to 0.15.0 (diff)
downloadgentoo-3a7bf5f8d6f4517a4f07cb9a6d5fd776e6f9ccba.tar.gz
gentoo-3a7bf5f8d6f4517a4f07cb9a6d5fd776e6f9ccba.tar.bz2
gentoo-3a7bf5f8d6f4517a4f07cb9a6d5fd776e6f9ccba.zip
dev-python/executing: Deselect test crashing on py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/executing')
-rw-r--r--dev-python/executing/executing-2.0.0.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-python/executing/executing-2.0.0.ebuild b/dev-python/executing/executing-2.0.0.ebuild
index 992a4b31cee4..a5e4ed0cc8c8 100644
--- a/dev-python/executing/executing-2.0.0.ebuild
+++ b/dev-python/executing/executing-2.0.0.ebuild
@@ -37,6 +37,16 @@ distutils_enable_tests pytest
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
python_test() {
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ python3.10)
+ EPYTEST_DESELECT+=(
+ # crashes with infinite recursion (?)
+ "tests/test_main.py::test_small_samples[1656dc52edd2385921104de7bb255ca369713f4b8c034ebeba5cf946058109bc.py]"
+ )
+ ;;
+ esac
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}