summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-19 09:16:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-19 09:16:32 +0200
commit5be0d6072e217d0f3362c2de6cfb0db0ce363b45 (patch)
tree5dd40f01849738245594362051d58609cf0bd692 /dev-python/executing
parentdev-python/importlib_metadata: Bump to 4.0.0 (diff)
downloadgentoo-5be0d6072e217d0f3362c2de6cfb0db0ce363b45.tar.gz
gentoo-5be0d6072e217d0f3362c2de6cfb0db0ce363b45.tar.bz2
gentoo-5be0d6072e217d0f3362c2de6cfb0db0ce363b45.zip
dev-python/executing: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/executing')
-rw-r--r--dev-python/executing/Manifest1
-rw-r--r--dev-python/executing/executing-0.6.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index 4cc57ad5e52f..4532a2330b36 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1 +1,2 @@
DIST executing-0.5.4.gh.tar.gz 330687 BLAKE2B 10f526dfb3a9f72dda788af97547e011425a56d1af73c30f5704fb8d348beb4e4538e118355dd415ec6125507ca9b2b015c02dc0bd81a2ef732a60aafb89f12a SHA512 3953ee1f6667c32fea28f964b395d53e99fa7869e27495a241f70179577865ec430ddfa07776995b6b1aaddd660adf6c6b61a8e8931589c0faeea94743fbc209
+DIST executing-0.6.0.gh.tar.gz 330731 BLAKE2B f6a86072907c5140aefb45beb46bcc8c6e3e242e2e821046e59f0eafe1d5c16efe3c08dd1b19b1ce85388fd9cc4757bfe586b95fb490a594cfee4f5e69b5a0af SHA512 5d2f621ff4cbfd55ac43b555f771b129ade5d20f882f4e5d6a060a1a099abad73cc4128c9e6bd32fccc40c4c85c51c28b3be40ab16f163e1ceaaad07f1936ab7
diff --git a/dev-python/executing/executing-0.6.0.ebuild b/dev-python/executing/executing-0.6.0.ebuild
new file mode 100644
index 000000000000..63116e793bef
--- /dev/null
+++ b/dev-python/executing/executing-0.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Get information about what a Python frame is currently doing"
+HOMEPAGE="
+ https://github.com/alexmojaki/executing/
+ https://pypi.org/project/executing/"
+SRC_URI="
+ https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+# asttokens is optional runtime dep
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # this test explodes when collected by pytest
+ "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
+ pytest -vv tests/test_pytest.py || die "Tests failed with ${EPYTHON}"
+}