summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-21 17:56:56 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-21 20:04:58 +0100
commitc81f6e3182a3aa1bdaac2331c639f77262ee929f (patch)
treea5f88a1317fa86150716d73fd25b9466d0937fcf /dev-python/expandvars
parentdev-python/pastedeploy: Bump to 3.1 (diff)
downloadgentoo-c81f6e3182a3aa1bdaac2331c639f77262ee929f.tar.gz
gentoo-c81f6e3182a3aa1bdaac2331c639f77262ee929f.tar.bz2
gentoo-c81f6e3182a3aa1bdaac2331c639f77262ee929f.zip
dev-python/expandvars: New package, v0.11.0
New build-time dependency of homemade build backend in dev-python/yarl. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/expandvars')
-rw-r--r--dev-python/expandvars/Manifest1
-rw-r--r--dev-python/expandvars/expandvars-0.11.0.ebuild41
-rw-r--r--dev-python/expandvars/metadata.xml12
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/expandvars/Manifest b/dev-python/expandvars/Manifest
new file mode 100644
index 000000000000..daa32f23ac2c
--- /dev/null
+++ b/dev-python/expandvars/Manifest
@@ -0,0 +1 @@
+DIST expandvars-0.11.0.gh.tar.gz 10663 BLAKE2B cfbcb8bedc61cc8b1e88d4774784518e15846f7ea5ddbf58bd016ea2043dd5b1c9e55af117f6482e05e9ae4ba07e01d0fb471a72719f38191f1a29a9f66387a9 SHA512 e8de6544f2d369728e35c8b862662f348f46673f836f8b14dbdcfdc3dbcb7efda80deb55f8bcd597037ac974752e2463d429ddda3b8502fe19c402c253babf7f
diff --git a/dev-python/expandvars/expandvars-0.11.0.ebuild b/dev-python/expandvars/expandvars-0.11.0.ebuild
new file mode 100644
index 000000000000..6936e00222b6
--- /dev/null
+++ b/dev-python/expandvars/expandvars-0.11.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Expand system variables Unix style"
+HOMEPAGE="
+ https://github.com/sayanarijit/expandvars/
+ https://pypi.org/project/expandvars/
+"
+SRC_URI="
+ https://github.com/sayanarijit/expandvars/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires toml, useless
+ tests/test_expandvars.py::test_version
+)
+
+src_prepare() {
+ # sigh
+ cat >> pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["poetry-core"]
+ build-backend = "poetry.core.masonry.api"
+ EOF
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/expandvars/metadata.xml b/dev-python/expandvars/metadata.xml
new file mode 100644
index 000000000000..d66a900919de
--- /dev/null
+++ b/dev-python/expandvars/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">sayanarijit/expandvars</remote-id>
+ <remote-id type="pypi">expandvars</remote-id>
+ </upstream>
+</pkgmetadata>