summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-06-18 16:39:54 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-06-18 16:39:54 -0400
commit835c7ad73f684e9947e69da3bdf67b78ea4fcf79 (patch)
tree4e96bdbac2384c238c81042ee63b072ad1350efb /dev-python/fido2/fido2-0.7.0.ebuild
parentmedia-radio/js8call: bump (diff)
downloadgentoo-835c7ad73f684e9947e69da3bdf67b78ea4fcf79.tar.gz
gentoo-835c7ad73f684e9947e69da3bdf67b78ea4fcf79.tar.bz2
gentoo-835c7ad73f684e9947e69da3bdf67b78ea4fcf79.zip
dev-python/fido2: bump to 0.7.0
Package-Manager: Portage-2.3.67, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'dev-python/fido2/fido2-0.7.0.ebuild')
-rw-r--r--dev-python/fido2/fido2-0.7.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/fido2/fido2-0.7.0.ebuild b/dev-python/fido2/fido2-0.7.0.ebuild
new file mode 100644
index 000000000000..bc1d3938cb32
--- /dev/null
+++ b/dev-python/fido2/fido2-0.7.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="https://github.com/Yubico/python-fido2"
+SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ examples? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}