summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-01-15 13:17:26 +0100
committerSam James <sam@gentoo.org>2022-01-28 05:16:43 +0000
commitc70d4167b9e811713d0c9e740f4e35cef4727235 (patch)
tree31068f8af1c11e59b3d672955cdef917f22b631d /dev-python/filebytes/filebytes-9999.ebuild
parentdev-python/yara-python: run tests, convert to PEP517 (diff)
downloadgentoo-c70d4167b9e811713d0c9e740f4e35cef4727235.tar.gz
gentoo-c70d4167b9e811713d0c9e740f4e35cef4727235.tar.bz2
gentoo-c70d4167b9e811713d0c9e740f4e35cef4727235.zip
dev-python/filebytes: new ebuild
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/filebytes/filebytes-9999.ebuild')
-rw-r--r--dev-python/filebytes/filebytes-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/filebytes/filebytes-9999.ebuild b/dev-python/filebytes/filebytes-9999.ebuild
new file mode 100644
index 000000000000..6dcf19310aed
--- /dev/null
+++ b/dev-python/filebytes/filebytes-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Classes/Types to read and edit executable files"
+HOMEPAGE="https://github.com/sashs/filebytes"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sashs/filebytes"
+else
+ SRC_URI="https://github.com/sashs/filebytes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"