summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-24 14:57:39 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-24 14:57:39 +0200
commit3ea0303eca34b95a8a730b4097db5ed0d83798c4 (patch)
treea88bb84d50ed3fbc82db4bed5e1062e5ea712359 /dev-python/flake8
parentdev-python/more-itertools: Remove old (diff)
downloadgentoo-3ea0303eca34b95a8a730b4097db5ed0d83798c4.tar.gz
gentoo-3ea0303eca34b95a8a730b4097db5ed0d83798c4.tar.bz2
gentoo-3ea0303eca34b95a8a730b4097db5ed0d83798c4.zip
dev-python/flake8: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-7.1.0.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 9d626586d654..520aaf1979ca 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,2 +1 @@
-DIST flake8-7.1.0.gh.tar.gz 138600 BLAKE2B df6781e676d4eccf296d5fc3d767643956799d1c99adccb32d0005951f0aca13b7e99ff7506f7026e9ed6c2dd78d5bdd02d9a25aaf64a1353097b8a9c02c5739 SHA512 0e970bdb0facff3a6e2ee33a74fe77ee1f7c80fbc517125df34d831ff897e222d0955d56fa9e9eedef83ccdc4e92aa7bbc583517d7b19a8cf1041790a225693a
DIST flake8-7.1.1.gh.tar.gz 138915 BLAKE2B 5c00c4a95f0757f7d3716270ca1de91580cb1731c700227d563c08798981c124c5789f40a5965ad49450a77601ab9638d04cb32ef9c13418720c4123ba2a7932 SHA512 310457e3c701f746d812cc76664bcb79c7cbc320af9d757ebbc13c847f2c3864770d9b945694b4b6abb773ae636e19175222c3dab74d34559beaa7835f1d9931
diff --git a/dev-python/flake8/flake8-7.1.0.ebuild b/dev-python/flake8/flake8-7.1.0.ebuild
deleted file mode 100644
index 32744afd4140..000000000000
--- a/dev-python/flake8/flake8-7.1.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="
- https://github.com/PyCQA/flake8/
- https://pypi.org/project/flake8/
-"
-SRC_URI="
- https://github.com/PyCQA/flake8/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- =dev-python/pyflakes-3.2*[${PYTHON_USEDEP}]
- =dev-python/pycodestyle-2.12*[${PYTHON_USEDEP}]
-"
-PDEPEND="
- =dev-python/mccabe-0.7*[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- ${PDEPEND}
- )
-"
-
-distutils_enable_sphinx docs/source \
- dev-python/sphinx-prompt \
- dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # fails if additional flake8 plugins are installed
- tests/integration/test_plugins.py::test_local_plugin_can_add_option
- )
- if [[ ${EPYTHON} == pypy3 ]]; then
- EPYTEST_DESELECT+=(
- # problem with pypy3.10 in dev-python/pyflakes
- # https://github.com/PyCQA/pyflakes/issues/779
- tests/integration/test_main.py::test_malformed_per_file_ignores_error
- tests/integration/test_main.py::test_tokenization_error_but_not_syntax_error
- tests/integration/test_main.py::test_tokenization_error_is_a_syntax_error
- )
- fi
-
- epytest
-}