summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:42:03 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:52:16 +0200
commit0feb08dc2e57a0042bc28c762b10dfc390183cbd (patch)
treea0cccc03ad9c5e5c4de491ac3de20f7507feccb8 /dev-python/flask-api
parentdev-python/flake8: Remove redundant versions (diff)
downloadgentoo-0feb08dc2e57a0042bc28c762b10dfc390183cbd.tar.gz
gentoo-0feb08dc2e57a0042bc28c762b10dfc390183cbd.tar.bz2
gentoo-0feb08dc2e57a0042bc28c762b10dfc390183cbd.zip
dev-python/flask-api: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-api')
-rw-r--r--dev-python/flask-api/Manifest1
-rw-r--r--dev-python/flask-api/flask-api-1.1.ebuild37
2 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/flask-api/Manifest b/dev-python/flask-api/Manifest
index 7b941f13e487..09bcfbe4a912 100644
--- a/dev-python/flask-api/Manifest
+++ b/dev-python/flask-api/Manifest
@@ -1,2 +1 @@
-DIST flask-api-1.1.tar.gz 235042 BLAKE2B b3c7e476c8ef1fa21f7e60aa1fb87ef5b40708ea96332ca0290d9355552bc5c195914da769b39ace1d34864c32989cf7f9856d070b1e6b690a6c1f60b495cabc SHA512 52bb983bf9a0f906f37b645ff907eaa6ee3bc557b51f8935817963f3d66d99689eeba6a3e17711974663ad5ede267f9c85eb1d11f27597fe63806dc9f9e7ea22
DIST flask-api-2.0.tar.gz 235593 BLAKE2B fadd746d91cc2c797a2e40ee6b11532eb0184a1289a692f8de844501a6656eaa1e87d10811119f267344185b22ed5c12bca43198d64d50ca8055ce95d0f62f19 SHA512 631e69e5a786598e6b5ef7e02c5c4f293eadd84d86fdf0155771d04fb6e87be5686756db90ab265cc097ae3d623c31dcebf5096a62c660d6f7d6fb1c3f3d4e3f
diff --git a/dev-python/flask-api/flask-api-1.1.ebuild b/dev-python/flask-api/flask-api-1.1.ebuild
deleted file mode 100644
index 69f4d0e2b650..000000000000
--- a/dev-python/flask-api/flask-api-1.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Browsable web APIs for Flask"
-HOMEPAGE="https://github.com/flask-api/flask-api"
-# pypi mirror don't have docs folder
-SRC_URI="https://github.com/flask-api/flask-api/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]"
-
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc docs/about/* docs/api-guide/* docs/index.md
-}
-
-python_test() {
- pytest -vv || die
-}