summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-08 06:52:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-08 06:52:53 +0200
commit478190988edf19bb8096133ae4d0d6f5ca87cb97 (patch)
tree1fc3cf3d4901a7a043d033032a0a951f4678852f /dev-python/flask-babel
parentdev-python/croniter: Bump to 1.3.10 (diff)
downloadgentoo-478190988edf19bb8096133ae4d0d6f5ca87cb97.tar.gz
gentoo-478190988edf19bb8096133ae4d0d6f5ca87cb97.tar.bz2
gentoo-478190988edf19bb8096133ae4d0d6f5ca87cb97.zip
dev-python/flask-babel: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-babel')
-rw-r--r--dev-python/flask-babel/Manifest1
-rw-r--r--dev-python/flask-babel/flask-babel-3.1.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/flask-babel/Manifest b/dev-python/flask-babel/Manifest
index 7777d086db48..4804cd451a1b 100644
--- a/dev-python/flask-babel/Manifest
+++ b/dev-python/flask-babel/Manifest
@@ -1 +1,2 @@
DIST flask-babel-3.0.1.gh.tar.gz 20367 BLAKE2B 760b3ff9b867ad14f138b75e3e13c9d40a9dd4fab1dcef57c062677d6e52b31340403125f13427b6f57487609794176055f888a277eacc2323281f6899f115d9 SHA512 d189aac67f5671c3053efa1c8049fc364c031a77568db7a502d63e2ea09867c981c12669752f1524faecaddd4594ab064249f08b8af50dfde7267322b50ed2af
+DIST flask-babel-3.1.0.gh.tar.gz 20625 BLAKE2B 44c0f6e0af8e9d48035819a98dcfe472af0e53d98486b3bca367227092d098e392e09b0383b08d0eb782732d235f6f519bf6f553ea751750a869fc5f4de4bdd2 SHA512 74faab1e259fe38caf583982bf7a3595440ef37ec223a68243fa43eadfd4d661055706ba8eb92d29f37586e6a27d4f00fbdf5be8443820346b35b9551b716fc7
diff --git a/dev-python/flask-babel/flask-babel-3.1.0.ebuild b/dev-python/flask-babel/flask-babel-3.1.0.ebuild
new file mode 100644
index 000000000000..9c422ccab908
--- /dev/null
+++ b/dev-python/flask-babel/flask-babel-3.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="i18n and l10n support for Flask based on Babel and pytz"
+HOMEPAGE="
+ https://python-babel.github.io/flask-babel/
+ https://github.com/python-babel/flask-babel/
+ https://pypi.org/project/flask-babel/
+"
+SRC_URI="
+ https://github.com/python-babel/flask-babel/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.12[${PYTHON_USEDEP}]
+ >=dev-python/flask-2.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.1[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2022.7[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/pallets-sphinx-themes
+distutils_enable_tests pytest
+
+src_prepare() {
+ # https://github.com/python-babel/flask-babel/pull/215
+ sed -i -e 's:^include:exclude:' pyproject.toml || die
+ # https://github.com/python-babel/flask-babel/pull/225
+ sed -i -e '/pytz/s:\^:>=:' pyproject.toml || die
+ distutils-r1_src_prepare
+}