summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-12-02 15:46:06 -0500
committerAaron Bauman <bman@gentoo.org>2020-12-02 15:47:36 -0500
commit36c867f82127c775231e5200caa0551f661aa866 (patch)
tree832092786fd56ba393d9e728ff46f180c8eb479f /dev-python/flask-cors/flask-cors-3.0.9.ebuild
parentdev-python/dataclasses: add backport note (diff)
downloadgentoo-36c867f82127c775231e5200caa0551f661aa866.tar.gz
gentoo-36c867f82127c775231e5200caa0551f661aa866.tar.bz2
gentoo-36c867f82127c775231e5200caa0551f661aa866.zip
dev-python/flask-cors: bump to 3.0.9 and add more py compats
Bug: https://bugs.gentoo.org/743256 Bug: https://bugs.gentoo.org/743646 Closes: https://bugs.gentoo.org/696640 Closes: https://bugs.gentoo.org/718834 Suggested-by: Guillaume Seren <guillaumeseren@gmail.com> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/flask-cors/flask-cors-3.0.9.ebuild')
-rw-r--r--dev-python/flask-cors/flask-cors-3.0.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/flask-cors/flask-cors-3.0.9.ebuild b/dev-python/flask-cors/flask-cors-3.0.9.ebuild
new file mode 100644
index 000000000000..c66a94783741
--- /dev/null
+++ b/dev-python/flask-cors/flask-cors-3.0.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/wcdolphin/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/corydolphin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A Flask extension for Cross Origin Resource Sharing (CORS)"
+HOMEPAGE="https://github.com/wcdolphin/flask-cors https://pypi.org/project/Flask-Cors/"
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="test? ( dev-python/packaging[${PYTHON_USEDEP}] )"
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme