summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-19 09:37:48 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-19 09:39:24 +0300
commit82e5587d45d875cb13a959e5cc27a36865954c3b (patch)
tree23d583c84fadcac6f52b12208cd2cc102d61c2c4 /dev-python/flask-htmlmin
parentapp-text/cssmin: new package (new rdep of flask-htmlmin) (diff)
downloadgentoo-82e5587d45d875cb13a959e5cc27a36865954c3b.tar.gz
gentoo-82e5587d45d875cb13a959e5cc27a36865954c3b.tar.bz2
gentoo-82e5587d45d875cb13a959e5cc27a36865954c3b.zip
dev-python/flask-htmlmin: add 2.2.0, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flask-htmlmin')
-rw-r--r--dev-python/flask-htmlmin/Manifest1
-rw-r--r--dev-python/flask-htmlmin/flask-htmlmin-2.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/flask-htmlmin/Manifest b/dev-python/flask-htmlmin/Manifest
index 2ff92db8fd0e..e89adb2596dc 100644
--- a/dev-python/flask-htmlmin/Manifest
+++ b/dev-python/flask-htmlmin/Manifest
@@ -1 +1,2 @@
DIST Flask-HTMLmin-2.1.0.gh.tar.gz 16395 BLAKE2B 259d3af497343d35fabb60e4aa1a832782de47fa78f2e8c6bdaa47a7e78efa8dfa756e87d0d03b5972f3e051a29dfff53b370cb1f3ee1f8a9e401d06c40894fd SHA512 3d3ea40bc5d802f41b0d3a99fcca59407b3948d9b4fe2300bc597bbfbaa851435276a7dcee4b6cc08cc52b0674a53fd655b7bb1c6504bd53ea9963600626a59a
+DIST Flask-HTMLmin-2.2.0.gh.tar.gz 17637 BLAKE2B 541ae212ba5bfd5e5881adb108d62c994248a7f851512d0fddedb001737620433cb46e267cdd66de73a353c6b357802eb89ea33c771153bc0acf3937c06f83c3 SHA512 24287ef93e99a16e7dde35ba6b7b8fefa06f11ce30fb47969313c3e0e1135ac8a2685aac06bc430d3253162f4f2bc7e8eed90ddda2092bbad092d4e0d09cb4fc
diff --git a/dev-python/flask-htmlmin/flask-htmlmin-2.2.0.ebuild b/dev-python/flask-htmlmin/flask-htmlmin-2.2.0.ebuild
new file mode 100644
index 000000000000..5cdcf795a321
--- /dev/null
+++ b/dev-python/flask-htmlmin/flask-htmlmin-2.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="Flask-HTMLmin-${PV}"
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Minimize your flask rendered html"
+HOMEPAGE="https://github.com/hamidfzm/Flask-HTMLmin"
+SRC_URI="
+ https://github.com/hamidfzm/Flask-HTMLmin/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/cssmin[${PYTHON_USEDEP}]
+ app-text/htmlmin[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/pytest-runner/d' -i setup.py || die
+ distutils-r1_src_prepare
+}