summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-16 05:21:30 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-16 06:04:16 +0100
commit99f0bbd7fda70f6ac53030a0414d46f8dada10b5 (patch)
tree637042b88b956e6b5d5c5b68ed1a2722128866ef /dev-python/flask
parentdev-python/pytest-subtests: Bump to 0.10.0 (diff)
downloadgentoo-99f0bbd7fda70f6ac53030a0414d46f8dada10b5.tar.gz
gentoo-99f0bbd7fda70f6ac53030a0414d46f8dada10b5.tar.bz2
gentoo-99f0bbd7fda70f6ac53030a0414d46f8dada10b5.zip
dev-python/flask: Bump to 2.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/Manifest1
-rw-r--r--dev-python/flask/flask-2.2.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 563992fae96f..8d9147df95f5 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1 +1,2 @@
DIST Flask-2.2.2.tar.gz 677389 BLAKE2B a7385c619dee7c25538a69bc514393c6efa2ee3cbd8394cde28c64a41d7252b4f12896728bf76a4b8bf5247cf19614bd9b8f94d7d82f22a6a8073011286758fc SHA512 d330398829cb0393e07a4dcf495a3939f0e8f7962c0a517fc866d333425dffe1ce8fd26e39a40445259028d46eff4566e97b3f5eba0d6bddf14b9d7bac138945
+DIST Flask-2.2.3.tar.gz 697599 BLAKE2B 619902202443567bc79111c15f19d0bea9e03b0fbd406e43c1f9d994975d9f529f8e58823d9f828bb8164bac6b6631ba1c00c3a1587b00afcb802082565248bc SHA512 de119d032b04eef80a99cee9658cac12f934e9a66d7dbb8304588d0c1320a8a19a8b0a78f69134a20ca26aa408db8686436c5c108ecc39e16b1eca1a3dea2d2c
diff --git a/dev-python/flask/flask-2.2.3.ebuild b/dev-python/flask/flask-2.2.3.ebuild
new file mode 100644
index 000000000000..486b6e0ce985
--- /dev/null
+++ b/dev-python/flask/flask-2.2.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="
+ https://palletsprojects.com/p/flask/
+ https://github.com/pallets/flask/
+ https://pypi.org/project/Flask/
+"
+MY_PN="Flask"
+MY_P="${MY_PN}-${PV}"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-2.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-2.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-3.6.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
+ !!dev-python/shiboken2
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-tabs \
+ dev-python/sphinxcontrib-log_cabinet
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:httpbin
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}