summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-05 19:24:36 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-05 20:45:03 +0100
commitba9836121c5b9c44f59c2c2e7cbfc1ba2590b73b (patch)
tree22b6087300d3278355e47e1d202b97e3d03c9629 /dev-python/fs
parentdev-python/mako: Add pypy support (diff)
downloadgentoo-ba9836121c5b9c44f59c2c2e7cbfc1ba2590b73b.tar.gz
gentoo-ba9836121c5b9c44f59c2c2e7cbfc1ba2590b73b.tar.bz2
gentoo-ba9836121c5b9c44f59c2c2e7cbfc1ba2590b73b.zip
dev-python/fs: New package, ebuild written by me
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/Manifest1
-rw-r--r--dev-python/fs/fs-0.5.4.ebuild45
-rw-r--r--dev-python/fs/metadata.xml16
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/fs/Manifest b/dev-python/fs/Manifest
new file mode 100644
index 000000000000..fbe789d9299a
--- /dev/null
+++ b/dev-python/fs/Manifest
@@ -0,0 +1 @@
+DIST fs-0.5.4.tar.gz 231333 SHA256 ba2cca8773435a7c86059d57cb4b8ea30fda40f8610941f7822d1ce3ffd36197 SHA512 d67c85f2816cf1a84c25664a6cf71dac551c3eec4eb34154bc92d52eb0efa9739adca6d0ec86b9978ff6af408cfa17b913ee8fd4c143cd2adf862ca0a1dd4c5d WHIRLPOOL 13ca379c6b563ec29985ff6dafa68f601c43459e75d7de99afaac55c21c7c5c581784f3f8dcb2b14b97adf00034e4890a8674f8a5263718c11b4c39051b1b902
diff --git a/dev-python/fs/fs-0.5.4.ebuild b/dev-python/fs/fs-0.5.4.ebuild
new file mode 100644
index 000000000000..f5e662e6602f
--- /dev/null
+++ b/dev-python/fs/fs-0.5.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Filesystem abstraction layer"
+HOMEPAGE="
+ http://pypi.python.org/pypi/fs
+ http://docs.pyfilesystem.org
+ http://www.willmcgugan.com/tag/fs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/dexml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+# Tries to access FUSE
+RESTRICT=test
+
+python_test() {
+ nosetests --verbose || die
+}
+
+pkg_postinst() {
+ optfeature "S3 support" dev-python/boto
+ optfeature "SFTP support" dev-python/paramiko
+ optfeature "Browser support" dev-python/wxpython
+}
diff --git a/dev-python/fs/metadata.xml b/dev-python/fs/metadata.xml
new file mode 100644
index 000000000000..a3293478ffe7
--- /dev/null
+++ b/dev-python/fs/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">fs</remote-id>
+ <doc>http://docs.pyfilesystem.org/</doc>
+ <maintainer status="unknown">
+ <email>will@willmcgugan.com</email>
+ <name>Will McGugan</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>