summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-29 06:52:17 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-29 07:51:33 +0100
commit4a8dc69c7b83c0dceb49531cd6995e47bffcbe7e (patch)
treeef8e9d9105b40711c85c07a29afcaf971fc866b6 /dev-python/google-api-core
parentdev-python/pytest-httpx: Bump to 0.33.0 (diff)
downloadgentoo-4a8dc69c7b83c0dceb49531cd6995e47bffcbe7e.tar.gz
gentoo-4a8dc69c7b83c0dceb49531cd6995e47bffcbe7e.tar.bz2
gentoo-4a8dc69c7b83c0dceb49531cd6995e47bffcbe7e.zip
dev-python/google-api-core: Bump to 2.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-2.22.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 01d97e28b488..4282e9614e57 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1 +1,2 @@
DIST python-api-core-2.21.0.gh.tar.gz 223405 BLAKE2B 696489182ece170ab955193e8940a2235cc07892b5bcc319abe482bf7b673545b95dadeb5c1b49624d772dc36c9bcf19d28a91ad6aae07ef3215002eabfe6d5e SHA512 f1517c2ed4027013bdd7c11c4dda0c5ee67450c78247907422b3bcdd8d2f83958fb3ee6c65749056b2eeb734b05d584f4e9a9d0d133e220e3779602ef22e5527
+DIST python-api-core-2.22.0.gh.tar.gz 222827 BLAKE2B f6098dce83c01f47c81e9348794f4015e3c9a82ce6b1b8d6292f3e55f69eb490544e8f1831f4e50aead2308c5490c9cb954a39f8565244bccd2a9bd5771e1015 SHA512 b5b6f2cd2ced4e74b50f93efe74bc2027f2761aee55aac1c4421d68aaf785550caf14343b4f92df9b17a6207ecbdefc5625fefc3fc5cd6ef006d79cdde4da119
diff --git a/dev-python/google-api-core/google-api-core-2.22.0.ebuild b/dev-python/google-api-core/google-api-core-2.22.0.ebuild
new file mode 100644
index 000000000000..3d0ae9c0fa06
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.22.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=python-api-core-${PV}
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-core/
+ https://pypi.org/project/google-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html
+"
+SRC_URI="
+ https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="grpc"
+
+RDEPEND="
+ >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/proto-plus-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ grpc? (
+ >=dev-python/grpcio-1.49.1[${PYTHON_USEDEP}]
+ >=dev-python/grpcio-status-1.49.1[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ >=dev-python/grpcio-1.49.1[${PYTHON_USEDEP}]
+ >=dev-python/grpcio-status-1.49.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # The grpc_gcp module is missing to perform a stress test
+ tests/unit/test_grpc_helpers.py
+)
+
+python_test() {
+ rm -rf google || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio tests
+}