summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-03 07:19:12 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-03 07:31:28 +0200
commit6086049937edacffa2c67f5b9de3e327ac7072fa (patch)
treeb2c45e9da6851159652bd8163515def622d39fe9 /dev-python/google-api-python-client
parentdev-python/aiosmtpd: skip single test needing git (diff)
downloadgentoo-6086049937edacffa2c67f5b9de3e327ac7072fa.tar.gz
gentoo-6086049937edacffa2c67f5b9de3e327ac7072fa.tar.bz2
gentoo-6086049937edacffa2c67f5b9de3e327ac7072fa.zip
dev-python/google-api-python-client: Bump to 2.125.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.125.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 3de4e22e73fe..422ac4cd7f2f 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,2 +1,3 @@
DIST google-api-python-client-2.122.0.tar.gz 11884905 BLAKE2B e22e9cc1b7e2afebbf0a1793e4d2c96d7e3d4b38e7266213d57b8db2eeedcc6c37a18bd0cc62c50fa84221dfea2bfc1ebd9c0cbe33fe4921662e50dd26ccde5d SHA512 dc17be212b975d700ca8ea333d0b1b7207f48cd870190154e14b94d5ae3f835c8f1fe63ed1ac267b1a1ab8a6916a6d55c479d5728801bbc74f842231eef71049
DIST google-api-python-client-2.124.0.tar.gz 11956565 BLAKE2B efa7273bb4c298804b331ea29218710a7427e614f830fe308763ef226ec392f3f1ea16e4d0f4f5ff98c987eba7c9331f0ff0ed6d32a89e9538d1fa18fcc40399 SHA512 4eacdbe4733a235b5c31c337c8cde18fef88691d55a8b988291dd5ff8cea786f67b4052eb2fb6e7aeb31631311f956e255469c3a1438f137c1eb03b43812f9c9
+DIST google-api-python-client-2.125.0.tar.gz 12020305 BLAKE2B a5c5beef66a40adc8eb9b56476bbd2eb6a5b9b1b528ccbfa964d9a2c65bdff2f949c52de5384faae6c7233be6f3357040a8fe531e0d21f48f822276a8e8a7ec9 SHA512 b2f456edacf515f83755bfaeb35677c3d3f6bef90d4d9be986a9191c3e8a0d80664784cc125524dd77792a329ff58fc9b35b0bd387248450a8b4e67ccaaa2f85
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.125.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.125.0.ebuild
new file mode 100644
index 000000000000..3961663be4b6
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.125.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}