summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-18 14:55:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-18 16:03:31 +0200
commitcd28940dc5553f9f04e15ed1fd3dbba2e9c4e64e (patch)
tree109f61bde62b82979d372f3f2bdda0ea5ec5a178 /dev-python/google-api-python-client
parentdev-python/virtualenv: Bump to 20.26.5 (diff)
downloadgentoo-cd28940dc5553f9f04e15ed1fd3dbba2e9c4e64e.tar.gz
gentoo-cd28940dc5553f9f04e15ed1fd3dbba2e9c4e64e.tar.bz2
gentoo-cd28940dc5553f9f04e15ed1fd3dbba2e9c4e64e.zip
dev-python/google-api-python-client: Bump to 2.146.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.146.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index d20f2631fa42..a16c6961d2fa 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,4 @@
DIST google_api_python_client-2.143.0.tar.gz 11695158 BLAKE2B bff768420c0303403268aff68059e81852da89e1a353bae23c86f17314842e17986b39d5c2410adc8991d3966b1c718e88a49a22ed0e222758928928c519077b SHA512 c977599521402fa3b63c432d8e058a4c5a2ac5cf15eadcba7d43200a2c5eb246bdd25a7fecb98ba3c2791d0d566a518d8274f9f77561d0fc7c78c7378a0b05c5
DIST google_api_python_client-2.144.0.tar.gz 11688778 BLAKE2B 98ca8b9d389876abf16c809f72a6ed907676ae6607acc82aa4656f8c05757459a478f820db6dc364eb7484a839f402c43c50136e254e5d0501eeeba1a1274a67 SHA512 3e6a9a59408f994dd8b5fa6ef5e49b069d907006a29c6631fdc25d6f2cc885cb919387b1cc385d6ecfccab450b4a4787787e401be9b2d7d97ba455595d72d297
DIST google_api_python_client-2.145.0.tar.gz 11714260 BLAKE2B eb672bdf74519f7dfd984412348ee0c62aa6a942acbb3182648bce2018af72ba6737924cb82c754a94c02f5b749c1bfdd07edb66bb2294b98e2b636cac7c2107 SHA512 33452e866798cd82f79e4d9a8708b4ca32a1e3118e37fbfe5b6e8b8b431167560c4175a5155499bca864fbdb59623368663e0025f71e8bd64b44e365ac889ad8
+DIST google_api_python_client-2.146.0.tar.gz 11690645 BLAKE2B 850f8b5b383ab8485b4b8aef77e94a18971498b51e1689aa707997931ba908e97e590681900beec42fc0f50adcbe8488657fbf0be0d8d5c6a55dc424a49ed86c SHA512 5789e69f1d279f8e53d40348af770aa03738853ebf19cfd4e50f23dca3412ca7d360993e4e00c4f0e654c65b3dbddfc2ffca069ebb26cc13b674bd622e90ae2a
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.146.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.146.0.ebuild
new file mode 100644
index 000000000000..58a0eb467bad
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.146.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}