summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-27 08:34:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-27 09:39:33 +0200
commitaf737fc420cf05483f86cd582d14360203821da5 (patch)
tree2ebbf4be1f3c51433899ccd5e1e03ca4dc473021 /dev-python/googleapis-common-protos/googleapis-common-protos-1.64.0.ebuild
parentdev-python/zipp: Bump to 3.20.1 (diff)
downloadgentoo-af737fc420cf05483f86cd582d14360203821da5.tar.gz
gentoo-af737fc420cf05483f86cd582d14360203821da5.tar.bz2
gentoo-af737fc420cf05483f86cd582d14360203821da5.zip
dev-python/googleapis-common-protos: Bump to 1.64.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/googleapis-common-protos/googleapis-common-protos-1.64.0.ebuild')
-rw-r--r--dev-python/googleapis-common-protos/googleapis-common-protos-1.64.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/googleapis-common-protos/googleapis-common-protos-1.64.0.ebuild b/dev-python/googleapis-common-protos/googleapis-common-protos-1.64.0.ebuild
new file mode 100644
index 000000000000..3f8a7e25daa6
--- /dev/null
+++ b/dev-python/googleapis-common-protos/googleapis-common-protos-1.64.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python classes generated from the common protos in the googleapis repository"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-common-protos/
+ https://pypi.org/project/googleapis-common-protos/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-6[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.15.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+# no tests as this is all generated code