summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-10 06:22:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-10 07:21:20 +0100
commitf7b79e503f907c1a4937714e71ef43ea67a0284a (patch)
treee6b6db137cf58986bcbdcc80d15b143adff8cb06 /dev-python/googleapis-common-protos
parentdev-python/mock: Bump to 5.0.1 (diff)
downloadgentoo-f7b79e503f907c1a4937714e71ef43ea67a0284a.tar.gz
gentoo-f7b79e503f907c1a4937714e71ef43ea67a0284a.tar.bz2
gentoo-f7b79e503f907c1a4937714e71ef43ea67a0284a.zip
dev-python/googleapis-common-protos: Bump to 1.58.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/googleapis-common-protos')
-rw-r--r--dev-python/googleapis-common-protos/Manifest1
-rw-r--r--dev-python/googleapis-common-protos/googleapis-common-protos-1.58.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/googleapis-common-protos/Manifest b/dev-python/googleapis-common-protos/Manifest
index 8fead90d5f66..e386dfbc9c65 100644
--- a/dev-python/googleapis-common-protos/Manifest
+++ b/dev-python/googleapis-common-protos/Manifest
@@ -1,2 +1,3 @@
DIST googleapis-common-protos-1.57.0.tar.gz 115316 BLAKE2B 3514774e537940a06db788646efcb9fbadbd5c0014844eaabcd4f24810cb13f8fc6983b4d451b5d5d3c8188e07548d60a42de9faebc0b6a8d883d61314405e04 SHA512 254f31631508770754a3bcc72a31705fc80aca87186291db73c20dd85ee209c71d97110dc2c9c742243ccb2121d38d77d3e1dc8a05eb4fc77ce07a2f32f7ef31
DIST googleapis-common-protos-1.57.1.tar.gz 115396 BLAKE2B 1ad20e61fe639bb8d0e3bb98cba80570805f913314bdb715d7e36cf50480292404c7bca23ab3d8701a14e4c1c30cbd4af711d3f20e0db3112477d2a1124b4e12 SHA512 ec1af9eef6bb359df5c4046a94c5b1c6769dcb1947fff98ece3ae3e27457a2afef71fe8444db391af2fa8f8ed64b4f73c18273e22fc4770d110c2e95a4c53037
+DIST googleapis-common-protos-1.58.0.tar.gz 117015 BLAKE2B 7821d83e40c42196517e27f9340741deb2c04fe15129c6e6f9c90c884ce6c4ffae38d456494d5271ac42f680595f82941df70bb2d94c5c20743d99c237a29354 SHA512 3e057e8dce7898ebf5c63ea1ded4f336ad5235ee6e7595739efd4c005b34f63d88481242f2d5a38b8d531d79d1957c2b79918bf61eb3ebc52227ec20b204cc82
diff --git a/dev-python/googleapis-common-protos/googleapis-common-protos-1.58.0.ebuild b/dev-python/googleapis-common-protos/googleapis-common-protos-1.58.0.ebuild
new file mode 100644
index 000000000000..94bfd512e2e2
--- /dev/null
+++ b/dev-python/googleapis-common-protos/googleapis-common-protos-1.58.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python classes generated from the common protos in the googleapis repository"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-common-protos/
+ https://pypi.org/project/googleapis-common-protos/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.15.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+# no tests as this is all generated code