summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-25 07:59:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-25 09:12:22 +0200
commitbea102570493ba559b0a1d6d0dfe3a02bd5ecde9 (patch)
tree031e1fba657dcd9fd6068093fd766ff7503b734f /dev-python/graphviz
parentpackage.mask: Last rite dev-python/aioredis (diff)
downloadgentoo-bea102570493ba559b0a1d6d0dfe3a02bd5ecde9.tar.gz
gentoo-bea102570493ba559b0a1d6d0dfe3a02bd5ecde9.tar.bz2
gentoo-bea102570493ba559b0a1d6d0dfe3a02bd5ecde9.zip
dev-python/graphviz: Bump to 0.20.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/graphviz')
-rw-r--r--dev-python/graphviz/Manifest1
-rw-r--r--dev-python/graphviz/graphviz-0.20.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/graphviz/Manifest b/dev-python/graphviz/Manifest
index ae691c390105..f06dc613bd02 100644
--- a/dev-python/graphviz/Manifest
+++ b/dev-python/graphviz/Manifest
@@ -1 +1,2 @@
+DIST graphviz-0.20.1.gh.tar.gz 188952 BLAKE2B 65d0b993e01492894b6d245c0869412b4956e5d55f9d8d490505c8f3477dc5ab98739cf0bf1aa1a15c4bacb2db4c2807659ce410ca65503c5876ffdc278e959f SHA512 34d340469856777f03b9c9e6d28f232908797bc1456a5b50104dd2f7dc8b7488afc7b29a564d57707ae96f3291f5ae90b8140ab64e378b82f271b5521763fb55
DIST graphviz-0.20.zip 255452 BLAKE2B 0bafa3af9d712e30bd6777d55d54c5a8055f8ad4c6e6ee8c9f936a5abf6e025d7179b2b72e9e0926378ae30e9b655d08507e815c67944123c6c222ecbcd4939d SHA512 8b30ac09913ec5860cf26cfc9e008b0feeda8d61274e346ec305087468b655ace115ff28e0ab96eb47d97127410213729d1131dd635771dcaedfae0bae0ca178
diff --git a/dev-python/graphviz/graphviz-0.20.1.ebuild b/dev-python/graphviz/graphviz-0.20.1.ebuild
new file mode 100644
index 000000000000..a0d7db4398ce
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.20.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="
+ https://graphviz.readthedocs.io/
+ https://github.com/xflr6/graphviz/
+ https://pypi.org/project/graphviz/
+"
+SRC_URI="
+ https://github.com/xflr6/graphviz/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ media-gfx/graphviz
+"
+BDEPEND="
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+ media-gfx/graphviz[gts,pdf]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" run-tests.py -vv -ra -l -Wdefault -p no:xdoctest ||
+ die "Tests failed with ${EPYTHON}"
+}