summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-18 06:05:27 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-18 06:05:27 +0200
commit2bc77d0be5396b1a14fe070a603ccee3a6a724d4 (patch)
tree162a47c766b39c0bfc494e498b4a2abe248c21cb /dev-python/griffe
parentdev-python/griffe: Remove old (diff)
downloadgentoo-2bc77d0be5396b1a14fe070a603ccee3a6a724d4.tar.gz
gentoo-2bc77d0be5396b1a14fe070a603ccee3a6a724d4.tar.bz2
gentoo-2bc77d0be5396b1a14fe070a603ccee3a6a724d4.zip
dev-python/griffe: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/griffe')
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-1.5.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index ef83ce5f5ee2..2390ad2d46e2 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1 +1,2 @@
DIST griffe-1.4.1.gh.tar.gz 383674 BLAKE2B d85a7c7dcc1406d361bd13b7a356b79d02d00d3bf24bb21a4f279b537d1001263b61af959ad27be50422d4cf56d5b75db79150b6d9bebfc4191217b2b9e4b09b SHA512 cb6c498daa6bce724c1cfd008e3b6c5c17ada8027a9cee58705a64739b7d049773d13fe08c7519777cb0c4870619d2b51426c2cad1d87404c6487ac10a60d703
+DIST griffe-1.5.0.gh.tar.gz 385479 BLAKE2B 835c1a8798b55305673635459a8de077ae71796aaf6fcd977fae602d5214ac4ef616cf05bc364fe20f1db63d0a6f8ace74ba40e9de34acd03536cf58e302f62f SHA512 3b5a5cd8a50696293ff6046afb3259ab7bb86d7b660d263b304fc5126970b06fbfff0b6da670a977c0df27c749f97bf9699d4fcc70cca9261769206664f3b612
diff --git a/dev-python/griffe/griffe-1.5.0.ebuild b/dev-python/griffe/griffe-1.5.0.ebuild
new file mode 100644
index 000000000000..b3ab8d048238
--- /dev/null
+++ b/dev-python/griffe/griffe-1.5.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/backports-strenum-1.3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)