summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-06 09:14:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-06 09:16:07 +0200
commit9dfba9af9143e2ccc016b14cca21474cd0c1cf08 (patch)
tree7a76b1d6bcbc67f5a972bec7e5fc8089d0ebe1dc /dev-python/h2/h2-4.1.0.ebuild
parentMove dev-python/{hyper-h2 → h2} (diff)
downloadgentoo-9dfba9af9143e2ccc016b14cca21474cd0c1cf08.tar.gz
gentoo-9dfba9af9143e2ccc016b14cca21474cd0c1cf08.tar.bz2
gentoo-9dfba9af9143e2ccc016b14cca21474cd0c1cf08.zip
dev-python/h2: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/h2/h2-4.1.0.ebuild')
-rw-r--r--dev-python/h2/h2-4.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/h2/h2-4.1.0.ebuild b/dev-python/h2/h2-4.1.0.ebuild
new file mode 100644
index 000000000000..1cfe581ac95d
--- /dev/null
+++ b/dev-python/h2/h2-4.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
+HOMEPAGE="https://python-hyper.org/h2/en/stable/ https://pypi.org/project/h2/"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/hyperframe-6.0[${PYTHON_USEDEP}]
+ <dev-python/hyperframe-7[${PYTHON_USEDEP}]
+ >=dev-python/hpack-4.0[${PYTHON_USEDEP}]
+ <dev-python/hpack-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest