summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-06-16 09:52:47 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-06-16 09:52:47 -0700
commit530bbb72bd99f7c0a1dcc14bd2be5d83e427a45a (patch)
tree0d2666d12a316bea6e436ab6b2809c23b924ff69 /dev-python/happybase
parentdev-python/gcs-oauth2-boto-plugin: add 3.0 (diff)
downloadgentoo-530bbb72bd99f7c0a1dcc14bd2be5d83e427a45a.tar.gz
gentoo-530bbb72bd99f7c0a1dcc14bd2be5d83e427a45a.tar.bz2
gentoo-530bbb72bd99f7c0a1dcc14bd2be5d83e427a45a.zip
dev-python/happybase: add 1.2.0, drop 0.9_p20210701
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/happybase')
-rw-r--r--dev-python/happybase/Manifest2
-rw-r--r--dev-python/happybase/happybase-1.2.0.ebuild (renamed from dev-python/happybase/happybase-0.9_p20210701.ebuild)16
2 files changed, 7 insertions, 11 deletions
diff --git a/dev-python/happybase/Manifest b/dev-python/happybase/Manifest
index 6c1b0e3212c6..a80401b18903 100644
--- a/dev-python/happybase/Manifest
+++ b/dev-python/happybase/Manifest
@@ -1 +1 @@
-DIST happybase-0.9_p20210701.tar.gz 106551 BLAKE2B 66e39d8db10b8b7adbab5b77462560d50a2a494e1cd9b0411abd1c928cb4b630e42ca0cc6740c35cc9a3b65dab8e637df6ae6d4105665fa21fa7668324c82ec5 SHA512 b55028e6fe8b1087e835b01d373af6357ecc495e82badda6bd1641d1d7ef79d5ec72d3336ca7112b5b6886d28b4a6296336c96b83ce58740ea5802c4f11ab12e
+DIST happybase-1.2.0.gh.tar.gz 43753 BLAKE2B 17c7762ca6268bbcfd1c379463a1f370aab354a526db2606e133b19c6b225e30561a079e22bee9f0232d74006c534d4c38d00ea1d651c93d94577dad9f60b0fe SHA512 0a93e390b854bdb047df8528aa6c19b3e0444c3d317feee4e2e0b8025792ece252422674d7b1feeb601b53966fec10e52593f2ad5119ec7f5e06128ad38ac2f6
diff --git a/dev-python/happybase/happybase-0.9_p20210701.ebuild b/dev-python/happybase/happybase-1.2.0.ebuild
index 0490d7a3842f..cbe7c8b68a9d 100644
--- a/dev-python/happybase/happybase-0.9_p20210701.ebuild
+++ b/dev-python/happybase/happybase-1.2.0.ebuild
@@ -1,17 +1,18 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
COMMIT_HASH="f5b6d104140c2be93e4175c0c844aaf094eb43da"
DESCRIPTION="A developer-friendly Python library to interact with Apache HBase"
HOMEPAGE="https://github.com/python-happybase/happybase https://happybase.readthedocs.io/"
-SRC_URI="https://github.com/python-happybase/happybase/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+SRC_URI="
+ https://github.com/python-happybase/happybase/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
LICENSE="MIT Apache-2.0"
SLOT="0"
@@ -26,8 +27,3 @@ RDEPEND="
RESTRICT="test"
distutils_enable_tests pytest
-
-python_prepare_all() {
- rm pytest.ini || die
- distutils-r1_python_prepare_all
-}