summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-13 06:22:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-13 06:46:14 +0200
commit6b8b82c014a535a9638377ce9d1844e19631d3ca (patch)
tree4f3f6fd3ccb808ae70f49ded8e030b59456bb3ba /dev-python/hatchling
parentdev-python/dkimpy: Bump to 1.1.4 (diff)
downloadgentoo-6b8b82c014a535a9638377ce9d1844e19631d3ca.tar.gz
gentoo-6b8b82c014a535a9638377ce9d1844e19631d3ca.tar.bz2
gentoo-6b8b82c014a535a9638377ce9d1844e19631d3ca.zip
dev-python/hatchling: Bump to 1.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hatchling')
-rw-r--r--dev-python/hatchling/Manifest1
-rw-r--r--dev-python/hatchling/hatchling-1.17.0.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/hatchling/Manifest b/dev-python/hatchling/Manifest
index 3e7f65019579..6254012f9d0a 100644
--- a/dev-python/hatchling/Manifest
+++ b/dev-python/hatchling/Manifest
@@ -4,3 +4,4 @@ DIST hatch-hatchling-v1.14.1.gh.tar.gz 378265 BLAKE2B ce990341dd4e41e98dbcc97af8
DIST hatch-hatchling-v1.15.0.gh.tar.gz 382326 BLAKE2B 14095fc4355baef2bd7ba6156dccb23d21fca4f3942a35fc4341764d4367b94413dc62e3701c43447883137db8261fd5c08ddb3b9688954102ed11c33767d1d4 SHA512 e8d9d557ce277063048ef49c58e8230fb021487c5b4ffafde9caa00c834e6e84aae3d0c7b2a8cbdbdfb18a177afc432da692fab8437630df539ca149dc2ebfc7
DIST hatch-hatchling-v1.16.0.gh.tar.gz 382820 BLAKE2B 4ab500afa1be4ee62f2def1877f6996aa07e1d8bce53eeb105e4c49a257ce32d1ff3eab3effd9aed63ac5570416ba7ecec54d06eafb642d58b9d7f6afafb535b SHA512 9abdc5e85694d9c1f17009920b452d9409deeed1903096ce3793f35e562567025a3e30846dfa8fbf3673ca9b4eb0267563b1c0e1c71c23271494c7ab3c78ea69
DIST hatch-hatchling-v1.16.1.gh.tar.gz 382929 BLAKE2B eea95700671a9875fa23bd710085802c570c1717f80c21c7dd45711f4577742d106a7ec128b9c86f2ea0e9c34743665bb9dd0a1052a6efb866893634d23448c0 SHA512 2e26e798e8d65de2e808dc5dc35451babb0df1c8cdf178a224e448c43b4755512cf8c7454b74dcd47a830d63691729926a3b24962348157a1adb844df9fd1e11
+DIST hatch-hatchling-v1.17.0.gh.tar.gz 383013 BLAKE2B 469d0d3e017d2dadcfdf9e2b4975f9e484739737a5c2d8fca9c55a4e519cf2e12b1ee44b3e26160476b3b990b15219a7075e692b58dcc4104b76b57395d8b0d1 SHA512 3649f2932c9963184deda5aac91726dad30ed88db2230377dc303714e0cdfd148b2fefc174ddeffff5cd95033bd984a35e3d297da02c29e4bfb7a6fb42f12dbd
diff --git a/dev-python/hatchling/hatchling-1.17.0.ebuild b/dev-python/hatchling/hatchling-1.17.0.ebuild
new file mode 100644
index 000000000000..a71cd5b7faf4
--- /dev/null
+++ b/dev-python/hatchling/hatchling-1.17.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_TESTED=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+
+inherit distutils-r1
+
+TAG=${P/-/-v}
+MY_P=hatch-${TAG}
+DESCRIPTION="Modern, extensible Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/hatchling/
+ https://github.com/pypa/hatch/
+"
+SRC_URI="
+ https://github.com/pypa/hatch/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/backend
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# deps are listed in backend/src/hatchling/ouroboros.py
+RDEPEND="
+ >=dev-python/editables-0.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ dev-python/trove-classifiers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local -x EPYTEST_DESELECT=(
+ # these run pip to install stuff
+ tests/backend/dep/test_core.py::test_dependency_found
+ tests/backend/dep/test_core.py::test_extra_met
+ tests/backend/dep/test_core.py::test_extra_no_dependencies
+ tests/backend/dep/test_core.py::test_extra_unmet
+ tests/backend/dep/test_core.py::test_unknown_extra
+ tests/backend/dep/test_core.py::test_version_unmet
+ # broken if CARGO is set
+ tests/backend/builders/test_app.py::TestBuildBootstrap::test_no_cargo
+ )
+
+ # top-level "tests" directory contains tests both for hatch
+ # and hatchling
+ cd "${WORKDIR}/${MY_P}" || die
+ local -x PYTHONPATH="src:${PYTHONPATH}"
+ # tests mock cargo subprocess call but the backend raises if CARGO
+ # is not set and shutil.which() can't find it
+ local -x CARGO=cargo
+ epytest tests/backend
+}