summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-10-19 23:11:58 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-10-19 23:11:58 +0200
commitb5ad473ac75c0eb3ab11a5e92cd326466bbe7b1c (patch)
treec358773ed196129c2443b07cad5fa8050b9e6c3a /dev-python/httpstat/httpstat-1.3.0.ebuild
parentdev-php/composer: bump to v1.10.15 (diff)
downloadgentoo-b5ad473ac75c0eb3ab11a5e92cd326466bbe7b1c.tar.gz
gentoo-b5ad473ac75c0eb3ab11a5e92cd326466bbe7b1c.tar.bz2
gentoo-b5ad473ac75c0eb3ab11a5e92cd326466bbe7b1c.zip
dev-python/httpstat: bump to v1.3.0
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/httpstat/httpstat-1.3.0.ebuild')
-rw-r--r--dev-python/httpstat/httpstat-1.3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/httpstat/httpstat-1.3.0.ebuild b/dev-python/httpstat/httpstat-1.3.0.ebuild
new file mode 100644
index 000000000000..975c753128f4
--- /dev/null
+++ b/dev-python/httpstat/httpstat-1.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"
+HOMEPAGE="https://github.com/reorx/httpstat"
+SRC_URI="https://github.com/reorx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="net-misc/curl:*"
+
+# Requires access to google.com and http2.akamai.com
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.1-gentoo-tests.patch )
+
+python_test() {
+ ./httpstat_test.sh || die
+}