summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-26 21:37:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-26 21:45:14 +0200
commit9d0e46bf53d4ca65ca8f6a4a67b8e91382a6648a (patch)
tree4ccf6169d7e2f821d29bda8c419372003cedee06 /dev-python/httpx
parentdev-python/pypy3_10: Backport a removal of debug print() as 7.3.13_p1 (diff)
downloadgentoo-9d0e46bf53d4ca65ca8f6a4a67b8e91382a6648a.tar.gz
gentoo-9d0e46bf53d4ca65ca8f6a4a67b8e91382a6648a.tar.bz2
gentoo-9d0e46bf53d4ca65ca8f6a4a67b8e91382a6648a.zip
dev-python/httpx: Avoid test dep on app-arch/brotli
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpx')
-rw-r--r--dev-python/httpx/httpx-0.25.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/httpx/httpx-0.25.0.ebuild b/dev-python/httpx/httpx-0.25.0.ebuild
index f705e90d5cef..d1530d4041e9 100644
--- a/dev-python/httpx/httpx-0.25.0.ebuild
+++ b/dev-python/httpx/httpx-0.25.0.ebuild
@@ -39,7 +39,6 @@ RDEPEND="
BDEPEND="
dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
test? (
- app-arch/brotli[python,${PYTHON_USEDEP}]
dev-python/anyio[${PYTHON_USEDEP}]
dev-python/brotlicffi[${PYTHON_USEDEP}]
dev-python/chardet[${PYTHON_USEDEP}]
@@ -60,6 +59,11 @@ src_prepare() {
sed -i -e '/^httpx =/d' pyproject.toml || die
fi
sed -i -e '/rich/s:,<14::' pyproject.toml || die
+
+ # use brotlicffi instead of brotli in tests
+ sed -i -e 's:import brotli:import brotlicffi as brotli:' \
+ tests/test_decoders.py || die
+
distutils-r1_src_prepare
}