summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-28 18:21:04 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-28 19:03:18 +0200
commit902cbc4c98ab37dfa312a90b27e61d30920ecb00 (patch)
tree14b6589301e442e8b86de6942c5f9a1042b15c4c /dev-python/humanfriendly/humanfriendly-8.2.ebuild
parentgames-rpg/manaplus: Fixed homepage (diff)
downloadgentoo-902cbc4c98ab37dfa312a90b27e61d30920ecb00.tar.gz
gentoo-902cbc4c98ab37dfa312a90b27e61d30920ecb00.tar.bz2
gentoo-902cbc4c98ab37dfa312a90b27e61d30920ecb00.zip
dev-python/humanfriendly: bump to 8.2, fix deps, support PyPy3+Py3.9
repoman --force was used because test dependencies depend on humanfriendly. Package-Manager: Portage-3.0.8, Repoman-3.0.1 RepoMan-Options: --force Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/humanfriendly/humanfriendly-8.2.ebuild')
-rw-r--r--dev-python/humanfriendly/humanfriendly-8.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/humanfriendly-8.2.ebuild b/dev-python/humanfriendly/humanfriendly-8.2.ebuild
new file mode 100644
index 000000000000..57700b106ef1
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-8.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.org/project/humanfriendly
+ https://github.com/xolox/python-humanfriendly
+ https://humanfriendly.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coloredlogs[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_test() {
+ pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
+}