summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-06-16 18:10:32 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-06-17 10:00:02 -0700
commita95914c2cbf71c67a294693d987207d1ea1cc9e4 (patch)
treeec329edb3eada779689bfde9a96f6b3438fcff9f /dev-python/hyperlink
parentdev-python/autobahn: Revision bump latest release for latest twisted (diff)
downloadgentoo-a95914c2cbf71c67a294693d987207d1ea1cc9e4.tar.gz
gentoo-a95914c2cbf71c67a294693d987207d1ea1cc9e4.tar.bz2
gentoo-a95914c2cbf71c67a294693d987207d1ea1cc9e4.zip
dev-python/hyperlink: New package, new dep of twisted-17.5.0
Package-Manager: Portage-2.3.6_p2, Repoman-2.3.2_p70
Diffstat (limited to 'dev-python/hyperlink')
-rw-r--r--dev-python/hyperlink/Manifest1
-rw-r--r--dev-python/hyperlink/hyperlink-17.1.1.ebuild30
-rw-r--r--dev-python/hyperlink/metadata.xml25
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/hyperlink/Manifest b/dev-python/hyperlink/Manifest
new file mode 100644
index 000000000000..873c528d8d32
--- /dev/null
+++ b/dev-python/hyperlink/Manifest
@@ -0,0 +1 @@
+DIST hyperlink-17.1.1.tar.gz 23067 SHA256 a7462dee03672b8f853c26e1ab9e3b1fd4c90a6efde64ab44a851c2472445018 SHA512 13b20fd54c6bb5d7de3c9a04133fdd848413d1308d9944a2288c76d5f8b9bb0c54401ca5ed53460112209806407497526f2e68a92d119656eb58a9a618e9b708 WHIRLPOOL 86f3dab9cd32805ce974d55920ab3a4cad032da740ce3e4fb103b20ee59a501400e302aa6c90f7d905bb49b78a460a4187a21fe34dc3a155b9234f6e48ea11f1
diff --git a/dev-python/hyperlink/hyperlink-17.1.1.ebuild b/dev-python/hyperlink/hyperlink-17.1.1.ebuild
new file mode 100644
index 000000000000..3ee721cda7cf
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-17.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.python.org/pypi/hyperlink"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v || die
+ cd test
+}
diff --git a/dev-python/hyperlink/metadata.xml b/dev-python/hyperlink/metadata.xml
new file mode 100644
index 000000000000..ddf1f449113f
--- /dev/null
+++ b/dev-python/hyperlink/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>mahmoud@hatnote.com</email>
+ <name>Mahmoud Hashemi</name>
+ </maintainer>
+ <remote-id type="pypi">hyperframe</remote-id>
+ </upstream>
+ <longdescription>
+ The humble, but powerful, URL runs everything around us.
+ Chances are you've used several just to read this text.
+ Hyperlink is a featureful, pure-Python implementation of the URL, with
+ an emphasis on correctness.
+ </longdescription>
+</pkgmetadata>