summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-04 20:10:38 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-04 20:54:57 +0300
commit72f71fca4fb0d78c28074cfc2f1f2912656aaaf7 (patch)
treeb7812a59c2869ad94123d6d1146a015c1b67696c /dev-python/identify
parentdev-python/pycodestyle: add 2.9.1 (diff)
downloadgentoo-72f71fca4fb0d78c28074cfc2f1f2912656aaaf7.tar.gz
gentoo-72f71fca4fb0d78c28074cfc2f1f2912656aaaf7.tar.bz2
gentoo-72f71fca4fb0d78c28074cfc2f1f2912656aaaf7.zip
dev-python/identify: add 2.5.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 28cb2159a070..d0bc39d953ae 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1,2 +1,3 @@
DIST identify-2.5.1.gh.tar.gz 101393 BLAKE2B 8586721838c427b00a7c70e842d2ab1a2f0437909d84d5cba6614aff3f8265f17b5137628bdd78e5f324fbf6a0fef8b5ca0246e6861af023c2d9a1a323cc43f6 SHA512 8b61dd03bcdb8908a1a7f3b13d66121bb4f4bb3aab57672bff55a84232dcff310214ed0a90cfcf79846da9abc111bff08761ec9dd40c8b9b183bfbbf365efac4
DIST identify-2.5.2.gh.tar.gz 101399 BLAKE2B f0ef048c6543b32016ad47a84e4b4b049a88424e496b159ce6ec1a1358172a87849e132b045a7345e818b02aee359e6d9458c458430a4d5d2b9f918cba685ed7 SHA512 72aaf406e5aa7acc83189820c389e82e90cf775541013e4ad91e5d25abdecd8526d1c47d203baa8ab8e5e028836da755a7045e74fded7e8e3167397557d4b1f0
+DIST identify-2.5.3.gh.tar.gz 101397 BLAKE2B 8782a4dfcea2d84facec9fefac8c7241c978ca1f494aa3e0602171dc017b41d24545ec7a3537b07a5e9962edcc4813fa4f45f76d807ba8ba69243041bc777d1b SHA512 d6cc5737b119498af5fb3cc9478881960b4d9532eec552622e942292ec3f1c75182f50ccc94fe7e1bb8993525c5e50fcdfd58881a9226da52fbe5feb3b83a8c3
diff --git a/dev-python/identify/identify-2.5.3.ebuild b/dev-python/identify/identify-2.5.3.ebuild
new file mode 100644
index 000000000000..8ce2bd5b0e7d
--- /dev/null
+++ b/dev-python/identify/identify-2.5.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest