summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-12 10:16:27 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-12 10:26:41 +0100
commit0091de42ba9a944f178f1df8b6b8ba255ccb3d76 (patch)
tree2a1458a93ffd2908bdd5f15fd4be476f76b4e65d /dev-python/imageio
parentdev-python/tifffile: New package, v2021.11.2, test dep of imageio (diff)
downloadgentoo-0091de42ba9a944f178f1df8b6b8ba255ccb3d76.tar.gz
gentoo-0091de42ba9a944f178f1df8b6b8ba255ccb3d76.tar.bz2
gentoo-0091de42ba9a944f178f1df8b6b8ba255ccb3d76.zip
dev-python/imageio: Add tifffile test-dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imageio')
-rw-r--r--dev-python/imageio/imageio-2.13.3-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/imageio/imageio-2.13.3-r1.ebuild b/dev-python/imageio/imageio-2.13.3-r1.ebuild
new file mode 100644
index 000000000000..72f7f04b1163
--- /dev/null
+++ b/dev-python/imageio/imageio-2.13.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="https://imageio.github.io/"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/tifffile[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+)
+
+EPYTEST_IGNORE=(
+ # Needs unpackaged imageio_ffmpeg
+ tests/test_ffmpeg.py
+ tests/test_ffmpeg_info.py
+)