summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-12-06 16:28:18 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2020-12-06 18:14:32 +0100
commita35788cfc6b462aa5dcca7f17c71daf9f3bfc7f5 (patch)
treee096375704aa832e5f9efb9d8f9133b4deac9ff0 /dev-python/imread
parentmedia-libs/vulkan-loader: x86 stable (bug #758680) (diff)
downloadgentoo-a35788cfc6b462aa5dcca7f17c71daf9f3bfc7f5.tar.gz
gentoo-a35788cfc6b462aa5dcca7f17c71daf9f3bfc7f5.tar.bz2
gentoo-a35788cfc6b462aa5dcca7f17c71daf9f3bfc7f5.zip
dev-python/imread: added missing dependencies
Closes: https://bugs.gentoo.org/753518 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-python/imread')
-rw-r--r--dev-python/imread/imread-0.7.3-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/imread/imread-0.7.3-r1.ebuild b/dev-python/imread/imread-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..fb98c1b82ed4
--- /dev/null
+++ b/dev-python/imread/imread-0.7.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read Image Files"
+HOMEPAGE="http://luispedro.org/software/imread/ https://github.com/luispedro/imread"
+SRC_URI="https://github.com/luispedro/imread/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libpng:0
+ media-libs/libwebp:0
+ media-libs/tiff:0
+ "
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ 'dev-python/numpydoc'
+
+distutils_enable_tests setup.py