summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 16:06:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 16:17:07 +0200
commit2f0a1525237a7e7ab6421f00c624f96b8cdd4c96 (patch)
tree0a0282d3507562abb688c3d574ce9336945b6263 /dev-python/iniparse
parentdev-python/immutables: Enable py3.10 (diff)
downloadgentoo-2f0a1525237a7e7ab6421f00c624f96b8cdd4c96.tar.gz
gentoo-2f0a1525237a7e7ab6421f00c624f96b8cdd4c96.tar.bz2
gentoo-2f0a1525237a7e7ab6421f00c624f96b8cdd4c96.zip
dev-python/iniparse: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/iniparse')
-rw-r--r--dev-python/iniparse/iniparse-0.5.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/iniparse/iniparse-0.5.ebuild b/dev-python/iniparse/iniparse-0.5.ebuild
index ef6e379353a0..777720c9ea55 100644
--- a/dev-python/iniparse/iniparse-0.5.ebuild
+++ b/dev-python/iniparse/iniparse-0.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Better INI parser for Python"
@@ -15,9 +15,8 @@ SLOT="0"
KEYWORDS="amd64 arm64 x86"
IUSE=""
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+BDEPEND=${RDEPEND}
python_test() {
"${EPYTHON}" runtests.py || die